Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
johnfulgor

Doom Builder II script compiler problem

Recommended Posts

Hello all,
that's a problem which is tormentig me from some time.
1)Create a new UDMF map
2)Add some sectors
3)Add 1/2 scripts
->Ok, everythig works
4)Add a script more
5)THE COMPILER STOPS WORKING! What I mean is that I press the compile button in the script window, but nothing happens. Even if I write "bla bla bla" in the script, no error message is issued.

This is a sample map:
http://uploadingit.com/file/bfa2fy5tusfrpwy5/lost.wad
Would some of you be so kind to open it in Doom Builder, open the script and compile it?
Thank you very much!
John

Share this post


Link to post

I have no clue what your problem may be, but have you tried compiling the script directly through acc.exe? You don't need Doom Builder to do so. Give ACC a plain text file containing your scripts and it'll output an object file (*.o) which you can place into the wad as a BEHAVIOR lump. It might be a useful workaround in your case.

ACC should be somewhere within the "Doom Builder 2\Compilers" directory. If you hate the command line, I'm 99% certain that you can just drag your text file and drop it on acc.exe, given the way it takes its parameters.

Share this post


Link to post
Mithran Denizen said:

I have no clue what your problem may be, but have you tried compiling the script directly through acc.exe? You don't need Doom Builder to do so. Give ACC a plain text file containing your scripts and it'll output an object file (*.o) which you can place into the wad as a BEHAVIOR lump. It might be a useful workaround in your case.

ACC should be somewhere within the "Doom Builder 2\Compilers" directory. If you hate the command line, I'm 99% certain that you can just drag your text file and drop it on acc.exe, given the way it takes its parameters.



Yes, in this way things are ok. But it's simpler and faster from the script window, if it was possible to make it work. I really don't know... It seems that the Compile button in the script window stops working.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×