Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Chocolate Doom problem: Psychedelic colors

Recommended Posts

I recently got a new laptop with windows 7 (my old one was Vista) and I copied all my doom stuff from my old hard drive into my new one. Prboom+ has been working fine, but whenever I use Chocolate Doom the colors go wild. Basically the colors of everything over a few feet from me look fucked up, while stuff directly in front of me looks normal. Any ideas on how to fix this?

Share this post

Link to post

If it's the problem I'm thinking of, then a temporary fix is to keep the "screen resolution" display settings window open when you play. I think you can go there directly by right clicking the desktop, and picking "screen resolution".

If I recall right, the problem has to do with windows not updating the palette for certain screen modes properly. On my laptop, plenty of 8-bit color games gave me a garbled palette like you describe and that's how I dealt with it.

I eventually changed the default screen mode to a non-native resolution for other reasons, and since then haven't noticed the garbled palette issues at all.

Here are a couple of semi-relevant links that I had saved some months ago, I'm not sure if they'll be of any use, but you never know:


Share this post

Link to post

Make sure the version you are using is fully up-to-date, and then use -8in32 as a parameter to the program.

Share this post

Link to post

Switch to 32 bit color depth in display settings in the setup tool. I'm slightly surprised because it should use this setting automatically on Windows 7. Are you reusing configuration files from another machine?

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now