Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kira

[SOLVED] XWE, Doombuilder and GLBoom-plus PNG support

Recommended Posts

So, I made a PNG texture and wanted to upload it with XWE as raw data. I placed it between markers HI_START and HI_END. Next I loaded the wad on DoomBuilder2 and the texture wasn't available. Being dumb, I said to myself "let's go adding the texture to PATCH and TEXTURE on XWE". Of course it didn't work.

Did I miss a step? Another question: am I doing this for nothing? Because I am not sure GLBoom-Plus support png textures anywhere else than F_SKY or INTERPIC and such...

Share this post


Link to post

If you use SLADE, it will let you add PNG to textures.


That said, the HI_ namespace is for replacement, so you should have a normal texture of the same name defined traditionally or within the TX_ namespace.

And, to answer your question, GLBoom+ is perfectly fine with PNG textures and sprites. Just look at the innards of Eternal's voodoo guns (vg.wad). :)

Share this post


Link to post

Thanks! I have a reason to try SLADE finally. Have I anything special to do? Will it load it as a patch and voila?

Share this post


Link to post

Just import it normally to your wad and it should work. SLADE doesn't try to convert files unless you tell it to.

Share this post


Link to post

Well, I have one more question: I did make an animated texture which is 512x512p in HI_START/HI_END with its 64x64 version in PP_START/P_END and... the texture is oversized ingame. It replaces the ROCKREDx animation.

Is it an issue I can't go through? SLADE works like a charm other than that BTW. Thanks Gez!

Edit : Nevermind, I've found the solution: resize REDROCKx in TEXTURE1 to 64x64. Hope it will be helpful to someone else!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×