Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Is my Doom 3 broken? Perfected Doom 3 mod not working.

Recommended Posts

Hey guys, I'm pretty new here, so if this is something really trivial or stupid, I'm sorry.

But what I'm whining about here is an error with Perfected Doom 3 mod. I saw some videos, and it looked incredible! You even get to fight the Icon of Sin again! So, naturally, I downloaded it and gave it it's own little folder to select via the mods menu on Doom 3.

Well, all was swell, until I started Doom 3 and clicked on it. It was loading fine, but when it finished loading, it gave me the "wrong game DLL API version" error, which I'm pretty sure means that I have to update the game to 1.3. But, I am pretty sure have that update. My game is updated to 1.3.1302. Am I missing something? Do I have the wrong update? Is this another post to go into Post Hell? Please give me some answers, friends!

Share this post

Link to post

Okay, so I found out that I had to update my game to 1.3.1...so I did! Unfortunately, this isn't an easy game to update ( I really don't think a game should be this hard just to update it ).

Well, my base folder and everything was an absolute mess from ages of custom maps and sound packs and things, so I re-installed Doom 3 to a new directory on a separate hard-drive, so there wouldn't be any chance of mods and things being in the way. Well, it was a completely fresh install and everything was finished installing, all was well, the game worked fine. So I downloaded the installer for 1.3.1...

Well, I swear this game either simply doesn't like me, or something is wrong with my copy, because when the update finished installing, and everything was well, it gave me an error after I tried to play the game.

Incoming giant wall of text.

DOOM 1.3.1302 win-x86 May 12 2005 10:40:52
2395 MHz AMD CPU with MMX & 3DNow! & SSE & SSE2 & SSE3 & HTT
5616 MB System Memory
512 MB Video Memory
Winsock Initialized
Found interface: {B6FE3A87-7F1F-4295-8023-82995D067D2E} Microsoft Virtual WiFi Miniport Adapter - NULL netmask - skipped
Found interface: {11488743-A470-4019-8466-9A8A28B19B0D} 802.11n Wireless LAN Card -
Found interface: {7345A258-7CF4-4C35-9351-1D053C53563D} Realtek PCIe GBE Family Controller -
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE & SSE2 & SSE3 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded pk4 C:\Program Files (x86)\Doom 3\base\game00.pk4 with checksum 0x29cdb978
Loaded pk4 C:\Program Files (x86)\Doom 3\base\game01.pk4 with checksum 0x51c6981f
Loaded pk4 C:\Program Files (x86)\Doom 3\base\game02.pk4 with checksum 0xf3ec6f7
Loaded pk4 C:\Program Files (x86)\Doom 3\base\game03.pk4 with checksum 0x5d4230ea
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak000.pk4 with checksum 0x28d208f1
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak001.pk4 with checksum 0x40244be0
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak002.pk4 with checksum 0xc51ecdcd
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak003.pk4 with checksum 0xcd79d028
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak004.pk4 with checksum 0x765e4f8b
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak005.pk4 with checksum 0x8ffc3621
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak006.pk4 with checksum 0x95b65ab
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak007.pk4 with checksum 0x666bdb3c
Loaded pk4 C:\Program Files (x86)\Doom 3\base\pak008.pk4 with checksum 0x23ae5993
Current search path:
C:\Program Files (x86)\Doom 3/base
C:\Program Files (x86)\Doom 3\base\pak008.pk4 (3 files)
C:\Program Files (x86)\Doom 3\base\pak007.pk4 (38 files)
C:\Program Files (x86)\Doom 3\base\pak006.pk4 (48 files)
C:\Program Files (x86)\Doom 3\base\pak005.pk4 (63 files)
C:\Program Files (x86)\Doom 3\base\pak004.pk4 (5137 files)
C:\Program Files (x86)\Doom 3\base\pak003.pk4 (4676 files)
C:\Program Files (x86)\Doom 3\base\pak002.pk4 (6120 files)
C:\Program Files (x86)\Doom 3\base\pak001.pk4 (8972 files)
C:\Program Files (x86)\Doom 3\base\pak000.pk4 (2698 files)
C:\Program Files (x86)\Doom 3\base\game03.pk4 (2 files)
C:\Program Files (x86)\Doom 3\base\game02.pk4 (2 files)
C:\Program Files (x86)\Doom 3\base\game01.pk4 (2 files)
C:\Program Files (x86)\Doom 3\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
Addon pk4s:
file system initialized.
----- Initializing Decls -----
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
5206 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
execing DoomConfig.cfg
couldn't exec autoexec.cfg
5206 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...calling CDS: ok
...created window @ 0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...creating GL context: succeeded
...making context current: succeeded

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
sound: STEREO
...using GL_ARB_multitexture
...using GL_ARB_texture_env_combine
...using GL_ARB_texture_cube_map
...using GL_ARB_texture_env_dot3
...using GL_ARB_texture_env_add
...using GL_ARB_texture_non_power_of_two
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 16.000000
...using GL_1.4_texture_lod_bias
X..GL_EXT_shared_texture_palette not found
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
...using GL_ATI_separate_stencil
...using GL_ATI_fragment_shader
...using GL_ARB_vertex_buffer_object
...using GL_ARB_vertex_program
...using GL_ARB_fragment_program
X..EXT_depth_bounds_test not found
---------- R_NV20_Init ----------
Not available.
----------- R200_Init -----------
---------- R_ARB2_Init ----------
----- R_ReloadARBPrograms -----
glprogs/arbVP_glasswarp.txt: File not found
glprogs/arbFP_glasswarp.txt: File not found
using ARB_vertex_buffer_object memory
using ARB2 renderSystem
found DLL in pak file: C:\Program Files (x86)\Doom 3\base\game03.pk4/gamex86.dll
copy gamex86.dll to C:\Program Files (x86)\Doom 3\base\gamex86.dll
3 22 800 600
Regenerated world, staticAllocCount = 0.
Shutting down sound hardware
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...shutting down QGL
...unloading OpenGL DLL
wrong game DLL API version

And I just don't know what went wrong. I'm pretty sure it means that game03.pk4 is broken or something, but it simply doesn't have any reason to be. This is a completely fresh install.

Can I get some help please? Also, if this is a stupid and really common and easy fix that I just can't find for unknown reasons, feel free to hell this thread, but please message me a link to the fix!

Also I think it's pretty bad that an update that's supposed to fix the game's bugs and glitches breaks it. That just seems really counter-productive to me.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now