Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Trouble converting map to UDMF

Recommended Posts

Hey guys.

I've been out of the Doom editing game for a while, and I'd like to convert one of my old maps (Doom format) into the new UDMF format to experiment with it. However, both WAD2UDMF and DoomConvert produce maps that, while work, show a ton of random floating vertexes when I load them into Doom Builder 2. The vertexes are sitting on lines but are not actually attached to them. When I move them/remove them, it often causes the map to be unplayable in ZDoom (latest stable and SVN builds).

I've tried copying the architecture manually from the source map to a new UDMF map however this map doesn't run at all. I've also tried creating a prefab out of the map's architecture, but it gives the same results.

Can anyone suggest a safe way to convert my old Doom format map into UDMF? Or can anyone spot something I've been doing wrong?

Here's a link to the WADs in question, plus the ZDoom crash report.

Any help would be greatly appreciated :)

Share this post

Link to post

I don't get those unattached vertices, at least I didn't find any. What I do get are things stuck in others, but those may be intentional, and a few missing textures.

Share this post

Link to post

Thanks for the reply :) I really appreciate it.

I downloaded the converted WAD, however it still crashes ZDoom for me. Doom Builder appears to display it correctly though - without those floating vertexes thankfully. Were you able to get it to run successfully?

Here's the crash report for zdoom.exe while running the updated WAD.

Do you have any thoughts? Maybe I'm doing something else wrong?

Share this post

Link to post

I must have done something to it while I had it open in GZDoombuilder. Sorry, about that.

Try this one.
I just downloaded and tested it. Ran fine in both, ZDoom and GZDoom. It can be run as a 7z file or extract it, your call.

Share this post

Link to post

Thanks again. This runs fine, however now I'm getting the floating vertexes issue again.

Here's a screenshot of an area as it appears in Doom Builder - I've highlighted a few of the vertexes in question, though there are many more.

I'm not familiar enough with UDMF to understand what's going on here - to me, it's even stranger that the vertexes are appearing in straight lines. On the occasions that ZDoom does run, it reports in the console that the map had "5613 invalid side references". I'm not sure if this has something to do with the problem.

Curious, I found that there were 4,545 extra vertices from the original map. Editing the TEXTMAP lump, I removed these. They were gone in Doom Builder and the map ran fine in ZDoom - UNTIL I make geometry changes. At this point it refuses to run again.

I'm pretty confused about this whole thing.

Edit: Correcting hyperlink

Share this post

Link to post

Clicking on the link I get a 403.

I did load the original map, tremor.wad (Doom2 format), into DB2r1599 and got a bunch of errors.

Just some thoughts about them:

I would think that the sector not closed errors definitely need fixing before the conversion process.

Those monsters stacked on top of each other, was that intended?

Most of the missing lower texture refer to sectors with an F_SKY1 ceiling, but some may be actual missing textures. There are too many of them for me to check out each one.

I haven't yet come across an extraneous vertex as you mentioned.

Share this post

Link to post
Kappes Buur said:

Those monsters stacked on top of each other, was that intended?

That's probably just the error checker ignoring the thing flags. I commited a fix for that just yesterday (revision 1604).

Share this post

Link to post

Sorry about the 403; here's the correct link.

I've fixed the sector errors (clearly I was rushing to release this WAD the first time round :P) and the missing textures, most of which were simply in dummy sectors. In terms of the monsters stacked on top of each other, boris is correct - the overlapping monsters have different difficulty flags.

I've uploaded a copy of this fixed map. Conversion with WAD2UDMF gives the same issue with the vertexes and still crashes upon adjusting the geometry. DoomConvert gives me too many vertexes however I've deleted a few and changed some lines around and it appears to still be stable. Manually removing 3000 loose vertexes doesn't sound like fun though, and the vertexes in the TEXTMAP lump don't have their indexes listed like they do in a WAD2UDMF conversion, so I wouldn't easily be able to remove them through that method either.

Share this post

Link to post
zarkyb said:

.... Manually removing 3000 loose vertexes doesn't sound like fun though, ......

Really strange about these vertices.
But you do not have to remove them at all.

"What ?" "Why ?"
You may well ask.

Slade3 will do it for you.

Convert tremorfixed.wad to UDMF as Utremorfixed.wad.

Load Utremorfixed.wad into Slade3r1344. You have to point it to a nodebuilder, in Editor - Preferences. Use ZDBSP 1.17.

Doubleclick on MAP01 to go into the map editor and 'save as' perhaps Utremorfixed2.wad.

Close the map editor and close Slade3. The message 'Slade has stopped working' is normal. Just click on 'Close the program'.

One side effect, though. For some reason Slade3 did not retain the extra lumps.

Now load Utremorfixed2.wad into Slade3 as well as tremorfixed.wad.
Copy/paste the missing lumps from tremorfixed.wad to Utremorfixed2.wad.
Save as Utremorfixed3.wad.

Load into Doombuilder2 for futher editing.

Share this post

Link to post

Thanks dude, I really appreciate your help :D WAD now loads and runs correctly, in both Doom Builder and ZDoom, and I've been editing for an hour or so now and it seems stable. Thanks again!

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this