Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Trouble Running Custom TNT Map [SOLVED]

Recommended Posts

Hey folks

This is probably a really idiotic problem but somehow it's left me scratching my head. Basically i've made a custom map using tnt.wad's resources (textures), trouble is running the wad.

When creating the wad in Doom Builder 2 the main IWAD is Doom 2 (i don't have any choice really, at least not to my knowledge?) and obviously when running the map it will need tnt.wad for the additional textures. The problem starts here, how am i supposed to run the custom wad with both doom2.wad and tnt.wad? Using Chocodoom i did "-file doom2.wad tnt.wad mymap.wad" and as probably an obvious result no dice. I tried "-file tnt.wad mymap.wad" and i just get "r_texturenumforname sw1brcom not found". I also tried "-file doom2.wad mywad.wad" for the sake of it and wasn't surprised it didn't work.

It's left me stuck a little, i'm not usually prone to these blank spots but right now i am. I can test the map fine in Doom Builder, although i'm using Zdoom to test it. What is the right way to run a custom map using both Doom 2 and tnt, or even just one or the other?

Share this post

Link to post

Tried it, unfortunately it produces the same error as mentioned: "r_texturenumforname sw1brcom not found". Not sure what this means exactly since the texture does exist.

The main iwad used to create the map was Doom 2 since it's the only option doom builder allows. From here i could only add resources, which is tnt.wad. Because of this i'm not sure if it requires both iwads?

Share this post

Link to post

If it works in ZDoom but doesn't work in Choco, my guess is that mymap.wad contains TEXTURE1 or TEXTURE2 lump and something is wrong with it.

Share this post

Link to post

Found out what the problem was. I had a few custom textures that weren't added to the TEXTURE1 or PNAMES lumps. Not sure how i overlooked it but it's all fixed now. Thanks for you help guys.

Just a shame my map breaks the seg and visplane limit just slightly but ah well.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this