Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
esselfortium

Back to Saturn X E1: we love fixing bugs

Recommended Posts

47 minutes ago, invictius said:

What does everyone figure to be the slowest system that will run this without frame drops on vanilla?  I used a p200 with mbf (only decent port with frame counter) and it would dip to 20 on itytd map 4.  Pulled out my p2-350, got down to about the low 20's on uv on the same map where you get the blue key.  If there's enough demand I'll do a vid of me playing the game on the hardware that could theoretically run it if the wad was somehow sent 20 years in the past!

 

If using vanilla I would be surprised to see any real framerate issues. IIRC one of the ports altered enemy AI to be a bit smarter but eats up more processing power, maybe it was MBF? Those processors were released well into the quake era...

Share this post


Link to post
1 minute ago, Vorpal said:

 

If using vanilla I would be surprised to see any real framerate issues. IIRC one of the ports altered enemy AI to be a bit smarter but eats up more processing power, maybe it was MBF? Those processors were released well into the quake era...

You're right, MBF's performance drop is about a quarter compared to vanilla:

 

https://www.vogons.org/viewtopic.php?f=7&t=40699

 

Too bad that there's no way to have a live fps counter in vanilla.  Maybe one day I'll look at combining the wad into one part so it can be run on doom95.

Share this post


Link to post

Found something funny...in map 15, the stairs leading to the secret blue key doesn't work :(. Played on Zandronum 3.0 alpha-170709-2004

This is the switch that raises the stairs, right?

 

1.jpg.1680c2e09afd7abd4dc0616277c1660f.jpg

 

And this happened for the stairs...

 

2.jpg.8c9c64c408c4d0e7409321d9b8f293d2.jpg

Share this post


Link to post

Have you any compatibility option set in Zandronum?

Share this post


Link to post

Try setting compat_stairs on ("Use buggier stair building") and see if the level works better this way.

Share this post


Link to post
18 minutes ago, Gez said:

Try setting compat_stairs on ("Use buggier stair building") and see if the level works better this way.

Ok, I was recording that map and that happened. I haven't bothered to enter to that compatibility option for some reason....

EDIT: Tried with all compat options and the stairs still doesn't work. Still researching the cause...

Edited by leodoom85

Share this post


Link to post
1 minute ago, esselfortium said:

Thanks for the report, I've confirmed it happens on my end too. Mechadon!

Yeah, I tried on GZDoom and PRBoom just in case. Same thing....fffffffffuuuuuuuuuuuuu!!!!!!!!

Share this post


Link to post

Oh God, mechadon what the fuck, WHY? you were supposed to fix a VPO in a different part of the map. :/

Share this post


Link to post

@Mechadon please please PM me and let me know what else might have been changed in this latest map15 build!

 

I've found and fixed the stairs bug on my end already, but I'm now concerned that there could be other problems that were missed in the latest update to this map. **shudders**

Share this post


Link to post

And I have the whole thing recorded lol....meaning that I'll probably alter the ending of map14 and the beginning of map15. 

Share this post


Link to post

I noticed that map31 has an incorrect texture on linedef 4679. Not game breaking, but it sticks out like a sore thumb to me.

 

qvQJ6RS.jpg

Share this post


Link to post

Huh, that's strange...I didn't touch any of that stuff in the last update though.  I'll take a look at it, but does anyone have any thoughts on what's causing that?

Share this post


Link to post
1 minute ago, Mechadon said:

Huh, that's strange...I didn't touch any of that stuff in the last update though.  I'll take a look at it, but does anyone have any thoughts on what's causing that?

Some lines on the sides of the stairs were facing the wrong direction and causing the stair build to not work.

Share this post


Link to post

Stairs are set up by tagging the first sector and then continuing from there based on the direction of adjacent lines, until the flat changes. The lines on the sides of the stairs were facing inwards, and on one of those side sectors the floor flat matched the stairs' flat, which caused it to try affecting that sector instead of the intended stair sectors.

Share this post


Link to post

Just sent you a PM essel.  Thanks for diagnosing and fixing the issue by the way.  I must have inadvertently changed a flat or flipped the wrong line without thinking about it :/

Share this post


Link to post
1 minute ago, Mechadon said:

Just sent you a PM essel.  Thanks for diagnosing and fixing the issue by the way.  I must have inadvertently changed a flat or flipped the wrong line without thinking about it :/

The floor flat of sector 555 was changed from MTDKGYF3 to the flat matching the stair sectors (BRNFGY01).

Share this post


Link to post

Mek, don't feel too bad, errors happen. I'm venting frustration about our endless torment, heh. If it wasn't you, the curse would strike elsewhere. :/

Share this post


Link to post

Fortunately I discovered that one while recording and I thought that I needed an archvile to "help me" :D

Share this post


Link to post

Yea I know you guys have had a ton of trouble getting a final version out there.  I'm not really sure how the flat got changed but it seems like I may have updated a bad version of the map (but who knows).  I really am sorry though, I should have been less lazy and did a full test run of the map before sending it off.

 

@leodoom85 Thank you very much for spotting the bug, I really appreciate it!

Share this post


Link to post

No problem and check the maps from map31 and above, just in case....I don't want to encounter some bugs like this while recording ;)

Share this post


Link to post
1 minute ago, esselfortium said:

Okay, 1.1.3 hotfix ready!

 

Aside from the map15 stairs bug fix this should be identical to 1.1.2. I didn't touch the map31 pillar texturing because at this point I'm not going to press my luck by even breathing on these maps if I can help it.

 

DownlARGH

Noice. Downloading it.

Share this post


Link to post

In before: changes one single texture, breaks the entire map

 

Thx for the update though. Don't be too hard on yourself mechadon, errors happen, even to the best of us ;)

 

 

Share this post


Link to post
38 minutes ago, Yugiboy85 said:

In before: changes one single texture, breaks the entire map

You'd have to use a different nodebuilder for that. And even then, the only thing broken would be demos. Unless it's a very, very bad combination of a map and a nodebuilder.

 

Replacing the SIDEDEFS lump should be enough:

https://drive.google.com/open?id=0B9DxOfPvG2G1aTNzbzNENG1mZUE

 

I mean, I won't promise you that nothing will break...

 

Edited by Da Werecat : link

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×