Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

I can't register on Realm667, what's the problem?

Recommended Posts

I tried to download some stuff from Realm667 and it said i had to register, i tried registering but it keept repeating "The password doesn't contain the required letters" i tried the password with numbers, and in mixed case, still nothing, how can i register successfully?

Share this post

Link to post

The site's currently hosting a trojan, so I'd wait until that's cleaned up before attempting to register since it's probably interfering with the process.

Share this post

Link to post
GreyGhost said:

The site's currently hosting a trojan

We call that "a feature"...

Sorry for the trouble atm, we are still trying to figure out where the security hole is. Disabling Javascript should do the job btw.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now