Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Putrefier performance

Recommended Posts

I'm trying to play Ed C.'s Putrefier, but I'm unfortunately experiencing rather poor performance. First off, here are my system specs:

Intel Core 2 Quad 3.00GHz
Radeon HD 6950 2GB

I downloaded the most recent build of GZDoom (r1505), along with trying some old ones, and in all of them the performance in certain areas is quite atrocious (gets down to around 20 frames per second in some cases). As Ed instructed in his Putrefier thread, I disabled fog (which did improve the frame rate somewhat, but did not eliminate the aforementioned large drops).

The only thing that returns the frame rate to its normal level is disabling dynamic lights (disabling all other dynamic light settings but leaving dynamic lights on does not help). The problem is that dynamic lights are clearly a huge part of the map's aesthetic quality, so turning them off seriously hurts the experience.

Has anyone else experienced this problem? Is there any other way to fix it besides disabling dynamic lights completely?

Share this post

Link to post

Try disabling shaders across the board, should help quite a bit.

Share this post

Link to post

If you are up to get your hands dirty with some hard job, uninstall your GPU and install the Intel HD Graphichs (it can run OpenGL games better than any ATI card). After you finish playing, uninstall the HD Graphics and install and update your GPU drivers again.

But don't try this unless you know exactly what you are doing.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now