Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ZDOOM - Escape Key Doesn't Work

Recommended Posts

Hey guys, I hope someone can point me in the right direction.

I've recently encountered a bit of an issue with zdoom & derivative ports like gzdoom. Apparently these programs aren't recognizing my escape key any more. Pressing escape does not bring up the main menu at all. I can only get to the main menu if I load up an IWAD and press any key other than escape. It doesn't only affect the main menu either. If I do manage to get into the main menu escape still doesn't work. I'm not able to move back one menu level or cancel a key binding in the 'customize controls' dialog. I'm pretty stumped by this.

At first I thought this was specific to a pwad I'm working on, but now that I've been looking out for it I see that this issue persists globally. I've even wiped zdoom off my system & reinstalled it in a different location. Same issue.

The key works properly outside of zdoom. I've tested it out in sveral other programs and works fine.

Any ideas?

Share this post

Link to post

Does the issue persist when you delete/rename your INI file? Bear in mind that, depending on your OS configuration, it may be putting the INI file somewhere else other than the ZDoom folder itself.

Share this post

Link to post

Yeah, I've tried deleting the zdoom-<username>.ini file too. Doesn't seem to have any effect. Is there another .ini file that I should be looking for? This .ini is in the same folder as zdoom. What other possible locations should I check?

My OS is sadly Vista 64x (old laptop).

Thanks for your help!

Edit: It turned out to be some sort of quirk in the OS that fixed itself after a restart.

Share this post

Link to post
This topic is now closed to further replies.