Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Trying to Get PRBOOM+ To work on OSX

Recommended Posts

So I am trying to get PRBOOM to compile for OSX, however, when I run ./configure I get the following...

checking for OpenGL support... no
configure: error: You must have the relevant OpenGL development libraries & headers installed to compile with OpenGL support

What am I missing? How do I get around this?

Share this post

Link to post

Ok so this seems to work....

./configure --disable-gl

but I WANT OpenGL, anyone know how to avoid this?

Share this post

Link to post

What it says: you need to install the relevant OpenGL development libraries & headers.

Do you have Xcode installed? It comes with the compilers and dev files for most of the system.

Share this post

Link to post

You must be talking about a Mac, with OSX.

checking for OpenGL support... no
-- you are missing the OpenGL libraries

Does OSX come with OpenGL libraries as standard ??

Most of us have to download libraries and install them.
Even SDL calls the OpenGL libraries.
I think Mosaic was one of the implementations of OpenGL.
Apple probably has their own special implementation.

(oops, fraggle beat me by seconds)

Share this post

Link to post

Thanks for attempting to help

Yes this is OSX (Still can't get my ubuntu partition to boot off the drive works fine on USB).

I am new to all of this but I would assume NVidia would support OpenGL right? So they should have drivers somewhere right? Are there instructions for installing the Headers/Drivers?

Share this post

Link to post

You don't need to compile anything, just download it from here: https://sourceforge.net/projects/prboom-plus/

How to make PrBoom+ work on OSX 10.7 and up.
See this post

Beware that Apple still clings to its own version of OpenGL, which is still 3.2 (modern one is 4.2), which may explain all the recent OpenGL troubles with Doom ports. Regardless of it, PrBoom+ on OpenGL mode works for me; I'm using a laptop with discrete card and I deliberately forced the discrete card to be always on (disable automatic switching on system preferences, or get the gfxCardStatus utility).

Share this post

Link to post

compiling latest prb+ from source:

iirc, opengl framework should be on the system by default, I don't think you need to install anything (check to see if /System/Library/Frameworks/OpenGL.Framework exists)

if you have that then you have everything you need for openGL, but the files aren't in the locations they're expected to be in by the prb+ configure scripts, so you need to make some symlinks:

ln -s /System/Library/Frameworks/OpenGL.Framework/Versions/A/Headers /usr/include/GL

ln -s /System/Library/Frameworks/OpenGL.Framework/Versions/A/Headers /usr/include/OpenGL

ln -s /System/Library/Frameworks/OpenGL.Framework/Versions/A/Libraries/libGL.dylib /usr/lib/libGL.dylib

ln -s /System/Library/Frameworks/OpenGL.Framework/Versions/A/Libraries/libGLU.dylib /usr/lib/libGLU.dylib

I think that's all I had to do, this was awhile ago so I hope I'm not forgetting any other steps.

printz said:

How to make PrBoom+ work on OSX 10.7 and up[/b].
See this post

It's cool that the fix is so simple, but midi playback in is fucked on os x 10.7+. Is there any option for music other than quicktime?

Share this post

Link to post

cheers :)

I notice a couple annoying quirks in gl-mode though in (on os x 10.8), for one I can't seem to get hi-res textures to work, also for some reason automap doesn't render lines. If those work fine for you then I must've messed something up myself somewhere. Or maybe it's the aforementioned outdated opengl.

Share this post

Link to post

What are you guys using to build PrBoom+ from source? The Rakefile from src/MAC?

Share this post

Link to post

EDIT: 04/26/2015

Just got a new compy. os x 10.10.3. Here's the steps to compile the latest prb+ from scratch:

- install xcode and command line tools
- install the following (I used macports):
--- automake, autoconf, libsdl, libsdl_net, libsdl_image, libsdl_mixer, libpng
- make some symlinks so the configure script can find your OpenGL libraries:

sudo ln -s ${GLPATH}/Headers/ /usr/include/GL
sudo ln -s ${GLPATH}/Libraries/libGL.dylib /usr/lib/libGL.dylib
sudo ln -s ${GLPATH}/Libraries/libGLU.dylib /usr/lib/libGLU.dylib
- change some environment variables so compilers know where macports stuff lives:
export C_INCLUDE_PATH=$C_INCLUDE_PATH:/opt/local/include
export LIBRARY_PATH=$LIBRARY_PATH:/opt/local/lib
- now you can finally follow the standard install procedure:
svn co https://svn.prboom.org/repos/branches/prboom-plus-24/prboom2
cd prboom2
sudo make install
- by default executables are created in /usr/local/games/, iwad folder is /usr/local/share/games/doom/

Hopefully this post can be useful if anyone stumbles across this thread. Or maybe I'll eventually come back and look it up if I ever have to do this again :D

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now