Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Ralphis

Zdoom 1.22 ANIMDEFS

Recommended Posts

Howdy,

So I'm working with Odamex which is based on older ZDoom versions. Maybe not much has changed since ZDoom 2.0 in this lump but I'm having some issues and hoping someone can shed some light on the correct way to lay this out.

WHAT I'M TRYING TO DO: Animate a flat.

First thing I'd like to do is take the existing fwater1-4 flats and make them cycle quickly at two tics. Here is what I currently have in my ANIMDEFS lump:

FLAT FWATER1
    pic 1 tics 2
    pic 2 tics 2
    pic 3 tics 2
    pic 4 tics 2
Doesn't seem to work though. Additionally, I'd like to set something similar up with an SWATER1-4 set of flats. I assume it will look the exact same.

What am I doing wrong? Any help is appreciated

Share this post


Link to post

Keep in mind that this old syntax is directly inherited from Hexen. And there is a big difference between Hexen-style animations and Doom-style animations...

First, a question: when you say it doesn't work, do you test it by going to the secret area of MAP01, with the imps and shotgun; or by going to MAP02? Because I tested that ANIMDEFS lump in (modern) ZDoom, and it didn't work in MAP01, while it worked in MAP02. And you know why?

MAP01 uses FWATER4. MAP02 uses FWATER1.

That's the big difference between Hexen and Doom animations. Hexen animations only work when the placed texture is the one that starts the animation.

So, can you get it to work for all textures in range? Yes! As explained on the wiki, you need to use a different syntax. It's a shorter one, too:

Flat FWATER1 Range FWATER4 Tics 2
I think this one too is old enough to have been around in ye olden days, so it probably should work in Odamex too. If it doesn't, you'll have to use ANIMATED...

Share this post


Link to post

Okay so I tried with Odamex itself and it didn't work at all anywhere.

So I wrote a bunch of random-keyboard mashing garbage in the ANIMDEFS code and tried again. Same result. Odamex didn't complain at all about not being able to parse the ANIMDEFS lump.

So I added an ANIMATED lump and edited it to change the FWATER1-4 animation speed to 2, and it worked.

Conclusion: Odamex does not support ANIMDEFS at all. Like, the lump doesn't even exist for it. But ANIMATED works.

Share this post


Link to post

It supports animdefs. I've already used it to animate a bunch of textures and to warp flats. For some reason it doesn't seem to work with animating the flats though. It also bitches at me in the console so maybe you made some sort of mistake with your lump?

I'll probably go through with the ANIMATED lump for the flats (though it's possible that the animdefs support for flat animation shows up in the code eventually).

Thanks for the leg work Gez

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×