Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
bradharding

DOOM Retro v4.3 (updated October 15, 2021)

Recommended Posts

Posted (edited)

Hi, I found a bug.

 

If you change the player face background colour with the console to anything but the default value (5), it will show in the wrong place if widescreen is on.

 

Also how do I bind something to the semicolon key? It doesn't recognise "semicolon" and ";" gets treated like the delimiter between commands.

Edited by ZigfriedYoshimitsu

Share this post


Link to post
19 hours ago, MrDowntempo said:

Any chance we can get a cvar that, when enabled, colors keyed doors on the map?

How about three CVARs? :P I implemented am_reddoorcolor, am_yellowdoorcolor and am_bluedoorcolor in v4.2. They are 160 by default, so there's no difference until you change them.

 

11 hours ago, ZigfriedYoshimitsu said:

Hi, I found a bug.

 

If you change the player face background colour with the console to anything but the default value (5), it will show in the wrong place if widescreen is on.

 

Also how do I bind something to the semicolon key? It doesn't recognise "semicolon" and ";" gets treated like the delimiter between commands.

Thanks for the report! I'll fix these in the next point release (which won't be too far away).

Share this post


Link to post

Hi everyone! I've just uploaded v4.2.1 of DOOM Retro. It includes several minor bugfixes and optimizations, and may be downloaded here. Here's what's changed:

  • DOOM Retro is now compiled using v16.11.2 of Microsoft Visual Studio Community 2019.
  • Optimizations have been made to further improve the overall performance and stability of DOOM Retro.
  • Minor changes have been made to text that is output to the console.
  • The framerate will no longer drop to 35 frames per second if the game is paused, or the menu or console is open.
  • A slight dithered effect is now applied to fade transitions when the fade CVAR is on.
  • A fade transition will now always be applied when exiting the help screen and the fade CVAR is on.
  • Translucency is now applied to megaspheres when the r_translucency CVAR is on.
  • The following changes have been made when the r_shake_damage CVAR is greater than 0% and god mode is enabled:
    • The maximum amount of time the screen will shake when the player is attacked has been reduced.
    • The screen will no longer shake if the player is in a sector with special 16 (“Damage -10% or -20% health”) or 4 (“Damage -10% or -20% health and light blinks (0.5 sec.)”).
  • Improvements have been made to the clipping of the bottom of sprites when in liquid and the r_liquid_clipsprites CVAR is on.
  • A bug has been fixed whereby an action couldn’t be bound to or unbound from the ; key using the bind and unbind CCMDs.
  • The background of the player’s face will now be positioned correctly when the facebackcolor CVAR is a value other than its default of 5 and the vid_widescreen CVAR is on.
  • Zooming in and out of the automap is now more responsive.
  • The M_LGTTL and M_SGTTL lumps will now be used as the titles in the load and savegame menus if replaced in a PWAD.
  • Further improvements have been made to the support for Chex Quest.
  • Further improvements have been made to the support for REKKR.
  • A bug has been fixed whereby par times weren’t being displayed on the intermission screen in some instances.
     

Share this post


Link to post
9 minutes ago, NieMaMordy said:

It appears that menu continues to be capped to 35 frames per second in the newest version

Testing at my end, everything appears to be working as intended. What FPS are displaying if you enable the vid_showfps CVAR? And is the vid_capfps CVAR 35?

Share this post


Link to post

I can confirm that the menu and console is not capped at 35 fps nor dropping FPS anymore. I play with uncapped FPS and it reaches 200 FPS on my end, so I don't see the error.

Share this post


Link to post

Unfortunately, I still get the same issues while strafing in the latest release - for some reason it stops registering on my end if I switch too quickly.

 

Still holding out hope for a smooth 35 FPS as well - I don't mean to be pushy about it, it just felt really nice that way.

Share this post


Link to post
6 hours ago, valkiriforce said:

Unfortunately, I still get the same issues while strafing in the latest release - for some reason it stops registering on my end if I switch too quickly.

 

Still holding out hope for a smooth 35 FPS as well - I don't mean to be pushy about it, it just felt really nice that way.

I thought I had resolved the 35 FPS issue, but the strafing issue you brought up I didn't get a chance to look at. By looking at your previous comment, to confirm, both these issues were not present in v4.1.2, but have been since v4.1.3?

 

EDIT: Actually, I understand what you mean by the the 35 FPS issue now. Interpolation is disabled when vid_capfps is 35 now (which is what I originally intended, but didn't implement correctly). But you want 35 FPS with interpolation on. I'll introduce a separate r_interpolation CVAR. 😁

Edited by bradharding

Share this post


Link to post

Doom Retro has become my go-to port.

Thank you for the work on it and for the updates to improve it Brad.

 

Share this post


Link to post

I think I brought this up a long time ago, but there's a bug wrt DEHACKED lump parsing. Specifically, I reused frame 73, the frame that calls Refire for the chainsaw, since it's redundant. This is fine normally but in Doom Retro it causes a strange effect where the chainsaw moves back and forth horizontally while firing.

 

EDIT: It's because of r_fixspriteoffsets. Also, is it just me or are the sounds playing back at a lower pitch?

 

EDIT 2: If you turn off r_fixspriteoffsets, one of the rocket launcher flash frames does a similar thing. And the super shotgun.

Edited by maxmanium

Share this post


Link to post
9 hours ago, bradharding said:

I thought I had resolved the 35 FPS issue, but the strafing issue you brought up I didn't get a chance to look at. By looking at your previous comment, to confirm, both these issues were not present in v4.1.2, but have been since v4.1.3?

 

EDIT: Actually, I understand what you mean by the the 35 FPS issue now. Interpolation is disabled when vid_capfps is 35 now (which is what I originally intended, but didn't implement correctly). But you want 35 FPS with interpolation on. I'll introduce a separate r_interpolation CVAR. 😁

I double-checked just to be sure, and the strafing issue only appears in 4.2 and above - it wasn't present in the 4.1.3 release or before it.

Share this post


Link to post
18 hours ago, NieMaMordy said:

It appears that menu continues to be capped to 35 frames per second in the newest version

yeah, it looks like it for me too, but upon looking at vid_showfps 1, i actually am running at 333 fps, but the camera movement is still really choppy looking

 

 

Share this post


Link to post
1 hour ago, Blue Phoenix said:

4.2.2:when picking up a medikit at low health I get the message 'you pick up a medikit you really /x1freally...'

Thanks @Blue Phoenix. This will be fixed in the next version.

Share this post


Link to post

hey Brad, can we get the old rocket trails back? At least have an option to enable it, because the new rocket trails are, if I'm being honest, are look not very good

Share this post


Link to post

Hello, I recently installed Doom Retro and have been really impressed with what you made.

I have one suggestion, is it possible to remove the fade from the automap? I feel like it serves no purpose, even aesthetically. At the very least I find the fade-out animation (from automap to gameplay) is a bit jarring and not as smooth as the fade-in animation.


Thanks again, this is awesome work and have been telling others to check this port out.
 

Share this post


Link to post
28 minutes ago, Carnifex said:

Hello, I recently installed Doom Retro and have been really impressed with what you made.

I have one suggestion, is it possible to remove the fade from the automap? I feel like it serves no purpose, even aesthetically. At the very least I find the fade-out animation (from automap to gameplay) is a bit jarring and not as smooth as the fade-in animation.


Thanks again, this is awesome work and have been telling others to check this port out.
 

You can disable the fade effect in the console by: ''fade off''

 

A lot of the visual effects can be turned off or on just with the console: https://github.com/bradharding/doomretro/wiki/CONSOLE-VARIABLES

Share this post


Link to post

I want to report what I think is a visual bug with Doom Retro.

I'm playing Memento Mori I, MAP 09: High-Tech Grave. I'm not using any other mods.

There is a nukage trap that rises and you can see how the visuals bug out in this gif I made: 


Compare this to footage of the same section from someone else (I timestamped it): 


I don't know what source port that person is running but it's definitely not Doom Retro since the video was uploaded in 2011.

I hope this helps.

Share this post


Link to post

Thanks @Carnifex. This problem is caused because the player's view is lowered slightly in DR when in liquid, and in that map the player walks through a self-referencing sector. I thought I had already accommodated for issues such as this, but I'll look into it further. In the meantime, you may enter "r_liquid_lowerview off" in the console.

Share this post


Link to post

Hell Knights don't seem to leave squished sprites when they get crushed, I just noticed in Map 06 of Doom II.

Share this post


Link to post

I do not know if it is a bug, but the name of the map sometimes appears inside the status bar, it seems that it is only fixed by restarting the application or making screenshots lol

 

1.png

Share this post


Link to post
8 hours ago, AntonLiniares said:

I do not know if it is a bug, but the name of the map sometimes appears inside the status bar, it seems that it is only fixed by restarting the application or making screenshots lol

 

8 hours ago, Lol 6 said:

Thought I was the only one having this problem

Thanks for letting me know. I can't seem to replicate this. Have either of you been previously using the automap on a 2nd display by any chance (that is, is the am_external CVAR on?) Or could you please provide steps on how to produce it?

 

EDIT: Actually, I think this may be related to having the menu open over the automap when 4:3...

EDIT: And fixed! :)

Edited by bradharding

Share this post


Link to post

Hey! It is just me or it really feels kinda weird when you change the level via IDCLEV cheat and all of your previous weapons come with you?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×