Crispy Doom 5.1 (Update: Jan 13, 2018)

When using the music pack and an sf2, some midis (an example being what plays in e1m8 of Double Impact) crackle sometimes. To make matters worse, with the official build, I am unable to use Timidity GUS patches in Native MIDI mode as i used to before (for example, in the autobuild builds)

Share this post


Link to post

Like I said, in version 5.0 all was ok... Fix it please. Also I would like an option, which disables a demo bar.

Edited by MAJ

Share this post


Link to post

It would help if we knew what brand your speakers are. Also, the possibility of the demo bar being disabled or optional is... unlikely.

Share this post


Link to post

I have monitor speakers and Sennheiser HD 280 Pro headphones.

Share this post


Link to post

I also noticed that the music sound in the game always higher than other sounds, but in Chocolate Doom all is ok with it. Is it fixable?

Edited by MAJ

Share this post


Link to post

@buvk I have seen that you have already filed an issue upstream at Choco's bug tracker. Thanks for that, this is exactly what I would have asked you for, as Crispy and Choco share the same low-level music code.

 

@MAJ Please check these settings (not my own picture) and make sure they are identical (and reasonable!) for both your speakers and head phones:

 

Set-the-bit-rate-as-per-devices-capacity

 

Please try to set all devices to e.g. "CD quality" for a first attempt.

 

@Danfun64 The 5.0 release and the daily snapshots are built against older versions of the SDL libraries (SDL 2.0.5 IIRC). The 5.1 release is built against the latest library versions. Could you please check if moving or renaming crispy-midiproc.exe out of the way makes a difference?

Edited by fabian

Share this post


Link to post
13 minutes ago, Woolie Wool said:

Not all sound devices support 24/192, you know.

 

2 hours ago, fabian said:

Please try to set all devices to e.g. "CD quality" for a first attempt.

Edited by fabian
1 person likes this

Share this post


Link to post

Renamed crispy-midiproc.exe to crispy-midiproc.bak . Built in Fluidsynth still crackles. Timidity GUS patches now work properly (and without any crackling). 

So basically crispy-midiproc.exe disables timidity support, and using the native windows synth still doesn't allow changing midi volume.

Share this post


Link to post
22 hours ago, fabian said:

@MAJ Please check these settings (not my own picture) and make sure they are identical (and reasonable!) for both your speakers and head phones:

 

Set-the-bit-rate-as-per-devices-capacity

 

Please try to set all devices to e.g. "CD quality" for a first attempt.

My headphones always had this maximum value for the best quality and I won't to change that, but my monitor speakers have only this unlikely... :(

Share this post


Link to post

I set my headphones and speakers to CD and DVD quality for test - it have no sense, "cartoon" sounds stays and high music sound\low other sounds on the same values. I also noticed that "cartoon" sounds are much louder.

P.S. Latest dev builds (16-17 jan, others are not checked) has no "cartoons"...

Edited by MAJ

Share this post


Link to post
On 1/16/2018 at 2:40 PM, Danfun64 said:

So basically crispy-midiproc.exe disables timidity support, and using the native windows synth still doesn't allow changing midi volume.

Making sure timidity was working was one of the things I checked when working on midiproc.  How exactly do you have timidity set up?

Share this post


Link to post

The only thing I did was set timidity_cfg_path. I didn't add in any dll's to the crispy doom package (except the music pack dlls, but those are irrelevant to SDL_mixer's built in timidity)

Edited by Danfun64

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now