Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
fabian

Crispy Doom 5.10.3 (Update: Aug 17, 2021)

Recommended Posts

With the 5.9.0 version, teleports seem different now. Like you come out of it and sometimes drop like you were in the air, or sometimes the flames look different or not there. Hard to explain.

Share this post


Link to post

^I think it was that bug. Seems normal in other wads and even other maps within TNT. (can't remember which maps it happened in; one was where you're following teleporters along the cliff in the outdoor mancubus area)

Edited by RottingZombie

Share this post


Link to post

Awesome. loving 5.9.0! I haven't used crispy in awhile. Used it a few times, along with chocolate. Ever since the widescreen support was added, I've been hooked on it. Now I'm constantly battling myself on which port to use more, Crispy or GZdoom. I've tried time and time again to recreate the same nostalgic feeling I had playing Doom for the first time on Doom95. Crispy Doom was just the right solution. And with Limit-removing, I can play pretty much any wad.

 

Thank you for the hard work and dedication, looking forward to future versions.

Share this post


Link to post
On 8/30/2020 at 5:07 PM, RottingZombie said:

Edit: I also want to add that this is my favorite Doom port because of one reason: All the stuff that alters vanilla behaviour/looks is color-coded in the crispness menu, so I know without having to remember a bunch of settings that I can just make sure everything is greyed out and running how I want. Please never change this :)

 

This isn't ever going to change. ;)

 

On 8/30/2020 at 10:50 PM, kokrean said:

@fabian It only happens when I open a crispy-doom.exe shortcut or bat with -record parameter within, but the game sound returns pausing the game at least 1 time.

 

Sorry, but I cannot reproduce this. Both music and SFX are normal for me no matter if I start the game with the -record parameter or -warp or from the menu.

Share this post


Link to post
On 8/28/2020 at 7:04 PM, kokrean said:

But when I open a shortcut with -record parameter the sounds not works but when I pause the game the sound returns.

I don't experience this either, in Linux. I'll try on Windows later.

 

Can you post the full shortcut target/command?

Share this post


Link to post

@plumsIn shortcut I use "-record rng -episode 1 -skill 4 -complevel 3"

In bat "crispy-doom.exe -record rng -episode 1 -skill 4 -complevel 3" 

and I tried just with "crispy-doom.exe -record rng" and happens the same.


Im using windows 7 x32, I tried with new 5.9.0, all sound options, doom 2 wad and no rest for living and nothing.

Edited by kokrean

Share this post


Link to post

I figure checking Chex Quest probably isnt the priority when updating Crispy, but I noticed today that it's having some weird texture bugs that Choco Doom isnt.  the problem also doesnt seem to be happening in Chex Quest 2

chexwtf1.png

chexwtf2.png

chexwtf3.png

Share this post


Link to post

Update Sep 04, 2020: Crispy Doom 5.9.1 is released!


Crispy Doom is a friendly fork of Chocolate Doom that provides a higher display resolution, removes the static limits of the Doom engine and offers further optional visual, tactical and physical enhancements while remaining entirely config file, savegame, netplay and demo compatible with the original.

 

Crispy Doom 5.9.1 is released on September 04, 2020 to fix some minor bugs.

 

Please visit the Crispy Doom homepage for more information:
https://github.com/fabiangreffrath/crispy-doom/releases

Binaries for Windows (x86) are available here:
https://github.com/fabiangreffrath/crispy-doom/releases/download/crispy-doom-5.9.1/crispy-doom-5.9.1-win32.zip

https://github.com/fabiangreffrath/crispy-doom/releases/download/crispy-doom-5.9.1/crispy-heretic-5.9.1-win32.zip


Have a lot of fun!

- Fabian

Share this post


Link to post
46 minutes ago, Mr.Unsmiley said:

I figure checking Chex Quest probably isnt the priority when updating Crispy, but I noticed today that it's having some weird texture bugs that Choco Doom isnt.  the problem also doesnt seem to be happening in Chex Quest 2

 

Oh yes, Chex Quest has priority, my son loves it! Do the texture glitches only appear in the latest release or were they already apparent before? Do you load chex.wad as the IWAD?

Share this post


Link to post
6 hours ago, fabian said:

 

Oh yes, Chex Quest has priority, my son loves it! Do the texture glitches only appear in the latest release or were they already apparent before? Do you load chex.wad as the IWAD?

 

yes it's the IWAD.  I just did a fresh install of 5.8 in its own folder and the bug wasnt happening there, then updated that folder to 5.9.1 and it was happening again.  so, yeah, it started with 5.9.0

Share this post


Link to post

I'm glad that you finally solved the sound problem, but the newer SDL versions had another problem - image distortion when the camera is rotated quickly. Is it fixable? I used to be able to solve this problem by replacing the SDL libraries, but now Crispy Doom gives me an error when starting with old libraries. I can also enable vsync to solve this problem, but then the mouse movements become imprecise and it is annoying.

Share this post


Link to post
41 minutes ago, fabian said:

Strange, I cannot reproduce this:

 

 

 

hmm... I just downloaded 5.9.1 on my brother's computer and his isnt having the issue either.  but I dont have any reason to believe it's a problem with my copy of the wad since it still works correctly in 5.8.  this is bizarre

Share this post


Link to post

@fabian I'm glad that you finally solved the sound problem, but the newer SDL versions had another problem - image distortion when the camera is rotated quickly. Is it fixable? I used to be able to solve this problem by replacing the SDL libraries, but now Crispy Doom gives me an error when starting with old libraries. I can also enable vsync to solve this problem, but then the mouse movements become imprecise and it is annoying.

Share this post


Link to post

@Mr.Unsmiley I can confirm that the texture bug is happening to me. I think the issue is that Sigil is being loaded and messing up the texture entries. Try running with -noautoload, or moving the Sigil wad somewhere where it won't be loaded.

Share this post


Link to post
50 minutes ago, plums said:

@Mr.Unsmiley I can confirm that the texture bug is happening to me. I think the issue is that Sigil is being loaded and messing up the texture entries. Try running with -noautoload, or moving the Sigil wad somewhere where it won't be loaded.

 

Backing this up -- I think it's the SIGIL autoload.

Share this post


Link to post

I've submitted a PR that fixes this, in the meantime you can use -noautoload or run with '-iwad chex.wad -file chex.wad' (so that the correct TEXTURE entries from chex.wad get loaded again after Sigil's).

Share this post


Link to post

Non fixed with 5.9.1, I guess that the problem is with my drivers or something.

 

Also, can you developers add a 60 and 120 fps limit option in crispness like uncapped? because it runs so laggy when I'm recording, like 70-250 fps unstable, I think that runs the game at 300 fps is not much necessary, framerate should be configurable. (Just a idea)

Edited by kokrean

Share this post


Link to post

Found a bug with the new levelstat implementation.  It works, but it is rounding down to the nearest ten second mark so in the example demo here it reads 0:25 on the end map screen, but the levelstat came out as 0:2 even.  I can open an issue on github if it is a legit bug and not just something with my setup, but I figured I would post the demo here and levelstat that I replicated the issue with.

 

 

levelstatbugdemocripsy5.9.1.zip

 

Edit: Love the wide-screen rendering mode and I might yet be converted!

Edited by Eric Claus

Share this post


Link to post

Hey, I have a niche issue and feel somewhat out of my depth. I have a Macbook I use for schoolwork and I'm trying to build Crispy on it. I found this guide to get it to compile, but I'm still getting errors. The first was a simple fix (the GNUmakefile was looking for config.make under the wrong name), but I'm lost after this. It finds the file, but immediately throws two errors and quits:

Quote

make: CC@: No such file or directory

make: *** [AppController.o] Error 1

 

Has anyone else gotten Crispy running on MacOS? I'm not super familiar with MacOS and even less so with compiling from source, so I'm pretty out of my depth here.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×