Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
fabian

Crispy Doom 5.2 (Update: June 20, 2018)

Recommended Posts

Cartoon sounds and incorrect sound balance are remained. :( I guess it unfixable? But why there is no cartoon sounds in dev builds?

 

P.S. And why all the text files has md format in release version?

Share this post


Link to post

It's most likely an issue between sdl_mixer and your sound card driver. Is it possible for you to play around with the SDL_AUDIODRIVER environment variable a bit and e.g. set it to "directsound" or "winmm" explicitly? Also, make sure the sample rate for your audio device isn't set to anything higher than 48khz. 

The dev builds use rather old sdl libraries and are not under my control. 

 

Regarding the text files, they have been converted to md format some two years ago and I merely copied them over from the source tree. 

Share this post


Link to post

When I choose more than 2 audiochannels, I hear cartoon sounds. And it's no matter what sample rate is.

 

P.S. Can you add vsync turn on\off option in crispness setings please?

Share this post


Link to post
31 minutes ago, MAJ said:

WP.S. Can you add vsync turn on\off option in crispness setings please?

 

Vsync is never really off, you can chose between capped (i.e. 35FPS) framerate and interpolated uncapped framerate (i.e. your screen's refresh rate) in the Crispness menu. If you want full uncapped framerate without Vsync (but please elaborate why you would want this), you can set `crispy_uncapped` to `1` in your crispy-doom.cfg file.

Share this post


Link to post
16 minutes ago, fabian said:

 

but please elaborate why you would want this

Of course, game runs much smooth with uncapped framerate without vsync on my 60Hz monitor. And it would be more convenient for me to have an option in game.

Share this post


Link to post
9 minutes ago, MAJ said:

Of course, game runs much smooth with uncapped framerate without vsync on my 60Hz monitor.

 

Sorry, but that's bogus! Your screen refreshes with 60FPs and the game renders a new scene with 60FPS. The game doesn't run any smother if you render 500FPS in between of which none makes it to the screen. Quite the contrary, will will encounter screen tearing if you leave Vsync off and have one CPU core at a constant 100%.

Share this post


Link to post

I didn't notice any screen tearing, but gameplay became less smooth. :\

Edited by MAJ

Share this post


Link to post

When I try to lower the music or turn it off, it also turns off my sound fx, I dident have this with crispy-doom 5.1..

how do i fix this problem?

 

Overal very nice release, love the smooth deminishing lightning and more sound channels select via menu,

props..

 

 

Share this post


Link to post

@MAJ I am sure this is purely subjective. The game cannot run smoother if it renders more frames than your screen can show.

 

@doomaddict82 Try to move crispy-midiproc.exe from the unsup/ directory one level up right next to crispy-doom.exe.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×