Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Marnetmar

Started working on a Half-Life map too!

Recommended Posts

Map is coming together nicely. I am used to Hammer. It seemed like a pain to do things.

Share this post


Link to post

Quick question, anyone know how to view lights/lightmaps/whatever you'd call them in hammer? I'd like to actually know what I'm doing when I place a light entity.

Share this post


Link to post

If you're referring to a preview, you don't. You compile the map with fast vis and normal RAD settings and see how it looks.

If you're referring to individual light settings, select the light and push ALT+ENTER to modify the light properties. ALT+ENTER applies for every other entity, point or otherwise, in Half-Life.

Only Hammer 4 has the functionality to preview the lightmap scale, but that's the best you get.

Share this post


Link to post

Have you compiled that yet? If not, how do you know you're happy with the scale of the space? Of course, that's hard when it's half built, but you could just enclose it in a big box.

It looks promising. I'm a sucker for lab-type spaces, though. I'll reserve any specific comments until it's further along.

Share this post


Link to post

Thanks! And I've attempted to compile it with a large box around it but I keep getting the following error:

** Executing...
** Command: Change Directory
** Parameters: C:/Program Files (x86)/Steam/steamapps/common/Half-Life/valve


** Executing...
** Command: C:/Program Files (x86)/Steam/steamapps/common/Half-Life/valve/hlcsg.exe
** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Half-Life\valve\maps\1sttb"

* Could not execute the command:
"C:/Program Files (x86)/Steam/steamapps/common/Half-Life/valve/hlcsg.exe" "C:\Program Files (x86)\Steam\steamapps\common\Half-Life\valve\maps\1sttb"
* Windows gave the error message:
"The system cannot find the file specified."


There's absolutely nothing wrong with any of these paths though, so what the hell?

Share this post


Link to post

Are you using Windows Vista or later? You may need to run the editor as administrator. It gets finicky with file priveleges otherwise

Share this post


Link to post

One of those paths has regular slashes instead of backslashes. Windows usually seems to work with either version, but that might be the problem.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×