Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
xbobby64

transparent texture help

Recommended Posts

That's not how you use gate textures. Why don't you open E1M3 and look at that place in your screenshot?

Share this post


Link to post

I'm guessing here that the black part of your texture is not cyan ? Cyan is the "transparent" colour in doom. Red 0,Green 255,Blue 255. Can be done in MS Paint.

Share this post


Link to post

<inb4 Gez sez there's no transparent colour in Doom>

It looks the texture's being wrapped around sectors and I think the only way I've managed to get transparency to work that way involved self-referencing sectors.

Share this post


Link to post

A - how it works :
1 - use it as a mid texture, and adjust its ofset.
normal walls are all but easy to get transparant.

A2 - How to make one and import it : using slade 3.

1 : export it as a PNG with transparancy inside, no cyan.
3 : import to your wad.
4 : convert it to DOOM gfx with the doom pallete.
5 : add it to patches and textures.

A3 - using XWE
2 : save it as a texture with that cyan bleu-ish tint for transparancy.
3 : import to your wad in XWE.
4 : add to patches and textures.

Share this post


Link to post

Bump for help :
Take the wired image i see on the top where you have transparant grates.
as there is clearly no blue or cyan, just pure transparancy.

Import that into your wad with slade as written above in my guide.
And then use it as a 'MID TEXTURE' not low or top.

Share this post


Link to post

are those mid-textures or did you just click on a wall and put it up there like all the other textures ?

make a sector with the ceiling 20 units above the ground.

then in the editor click a linedef of that sector,
go to that linedef its properties, and then assign a 'MID-TEXTURE' as your grate. and look around.

*corrected - RE READ.

also when converting the grate texture do not choose 'global pallete'
straight under the preview but change it to doom. you are using the wrong pallete looking at how litle detail is left.

Share this post


Link to post

xbobby64, here are two possible solutions. One is to export your image in whatever image editor that you use as a 32-bit or 8-bit PNG, the important part is that the image uses real transparency via the alpha channel. The other option is to use any color you want as a stand-in for transparency, and make sure that when you convert your graphic to patch format in Slade that you tell it what your transparency color is (there's an option for it in the lower half of the conversion pop-up window).

Also, you need to apply the texture as the mid-texture (not upper or lower texture) on a two-sided line. It's generally a good idea to apply it on both sides of the line, unless you want it to disappear when standing on the other side.

Let me know if you need further help or clarification.

hawkwind said:

I'm guessing here that the black part of your texture is not cyan ? Cyan is the "transparent" colour in doom. Red 0,Green 255,Blue 255. Can be done in MS Paint.

Please don't spread this misinformation.

Share this post


Link to post
hawkwind said:

I'm guessing here that the black part of your texture is not cyan ? Cyan is the "transparent" colour in doom. Red 0,Green 255,Blue 255. Can be done in MS Paint.

There's no cyan in Doom. And what GreyGhost said.

At most, cyan is the transparent color in some utilities people have used to import BMPs into Doom wads. It's not the only color, either, since magenta (red 255, green 0, blue 255) and teal (0/47/47) have been used too.

FireFish said:

How to make one and import it : using slade 3.

1 : export it as a PNG with transparancy inside, no cyan.

For reference, SLADE is perfectly able to convert cyan or any other color to transparency.



See that "Transparent colour" radio box? Tick it. You can choose the color (it's set to cyan by default because of how many people use a cyan background because they mistakenly think it's the official transparent color in Doom; but you can change it) and you can even click on a background pixel in the "current graphic" preview to set the transparent color.

FireFish said:

also when converting the grate texture do not choose 'global pallete'
straight under the preview but change it to doom. you are using the wrong pallete looking at how litle detail is left.


If you have set doom.wad (or doom2.wad, tnt.wad, plutonia.wad, etc.) as the base resource archive, the global palette will be the Doom palette.

Share this post


Link to post

A couple of changes I'd suggest are to add support posts for your grates so they look less like paper cut-outs and fix the texture so it tiles properly, that'll save having to split linedefs and manually align stuff.


(1920x1200 - 380k)

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×