Running GZDoom on linux with intel GMA 3150 - a guide

For the past few days I'd been trying to run GZDoom on my low-spec machine. First I encountered problems with compilation from source and once I eventually succeeded, it turned out my GPU was supposedly too weak to handle the engine. Solving those problems took me a lot of reading and searching and I managed to finally run GZDoom succesfully at 3 a.m. last night. I figured there might be others facing similar problems. So here is what I learned:

For starters, here is my machine's specification:

Acer Aspire One D257 (a netbook)
CPU: Intel Atom N570 (1.66 GHz)
RAM: 2 GB DDR3 1333 MHz*
GPU: Intel GMA 3150
OS: Linux Mint 16

*the computer originally came with 1 GB of RAM, but the motherboard supports up to 2GB so I recently upgraded the memory.

1. Compiling GZDoom from source

Note: the following information was valid for source downloaded on May 16th 2014. I assume the developer will fix it in the future.

In order to compile GZDoom I followed this guide:

http://zdoom.org/wiki/Compile_GZDoom_on_Linux

Everything was going fine until I reached the "Compile GZDoom" step. The compiler returned errors:

CMake Error at src/CMakeLists.txt:259 (message):
Could not find GLEW library files

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
GLEW_LIBRARY
linked by target "zdoom" in directory /home/(my name)/gzdoom_build/gzdoom/src

-- Configuring incomplete, errors occurred!
I managed to find a solution on official GZDoom forum so all the credit goes to guys from this thread (especially Skyrimguy):

http://forum.drdteam.org/viewtopic.php?f=24&t=6307

In order for the program to compile, a slight change has to be made in src/CMakeLists.txt

Open the file and find line 256. Lines 256-259 should look like this:
find_library( GLEW_LIBRARY glew32 )

if( NOT GLEW_LIBRARY )
	message( SEND_ERROR "Could not find GLEW library files" )
Write additional info so the final result is this:
find_library( GLEW_LIBRARY
	NAMES GLEW glew glew32 )

if( NOT GLEW_LIBRARY )
	message( SEND_ERROR "Could not find GLEW library files" )
Now you can compile GZDoom and proceed with further steps according to the guide on Zdoom.org's wiki. It worked for me.

2. Running GZDoom on Intel GMA 3150

After I successfully compiled GZDoom and tried to run it, I received an error saying:
Unsupported OpenGL version.
At least GL 2.0 is required to run GZDoom.
It was probably a fault of outdated Linux drivers (I could run GZDoom on the same computer on Windows 7 without any problems), but I couldn't find a guide on how to update Intel drivers on my Linux distribution. You can check your version by typing the following command in your terminal:
glxinfo | grep version
It returns the following info on my computer:
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 1.4 Mesa 9.2.1
As you can see, the OpenGL's version is 1.4. However, there is a workaround.

First of all, install driconf, if you don't have it already
sudo apt-get install driconf
Make sure GZdoom in installed on your system according to instructions on Zdoom.org's wiki, then run driconf. You will see a graphical interface. Click the "add" button under the "Application settings", write "gzdoom" (no quotes) in both lines and click OK. Then, select GZdoom from the dropdown list under "Application settings" and use the "add setting" dropdown menu to add the following options:

Performance --> Enable limited ARB_fragment_shader support on 915/945

Debugging --> Enable stub ARB_occlusion_query support on 915/945

Make sure, both options are set to "YES"

Close driconf and run GZDoom. It should run fine now :)

The game runs perfectly smoothly for me, with constant 60 FPS. I occasionally get graphical glitches, but I haven't figured out why yet. It's very hard to catch them on a screenshot, because they occur randomly for no longer than a frame or two. They also appear quite rarely - sometimes no more than once or twice per level. I THINK they occur less frequently the lower the resolution so I set mine to 640x480, although the game runs smoothly even on 1024x600 (the maximum I can set).

That would be all, I hope you find those tips helpful and can run GZDoom with less frustration than I initially experienced.

I'm off to killing imps and demons.

Share this post


Link to post

Glad you solved it, and kudos for writing your solution down instead of just saying "I figured it out" and moving on.

Share this post


Link to post

Thanks for kind words, I hope someone will find the guide useful. I know Intel chips often cause problems and are quickly dismissed as "too shitty to play games". I'm not denying the fact - I can confirm for instance that Intel GMA 3150 is absolutely HORRIBLE with any form of dynamic lighting, but sometimes there are some solutions to make it work better than initially expected.

Share this post


Link to post

Patrol1985 said:
The game runs perfectly smoothly for me, with constant 60 FPS. I occasionally get graphical glitches, but I haven't figured out why yet. [/B]

Maybe because your graphics chipset isn't actually supported by gzdoom ? :-)

Share this post


Link to post
VGA said:

Maybe because your graphics chipset isn't actually supported by gzdoom ? :-)


Naaaah, that can't be it! :P :P :P

Share this post


Link to post

Thanks for the guide, I have a subnotebook with an Intel GMA 950 and I get the same error message, though I'm running Windows. The graphics card only supports OpenGL 1.4. Would it still be possible to get GZDoom to run on my computer somehow?

Share this post


Link to post
Cire said:

Thanks for the guide, I have a subnotebook with an Intel GMA 950 and I get the same error message, though I'm running Windows. The graphics card only supports OpenGL 1.4. Would it still be possible to get GZDoom to run on my computer somehow?


I seriously doubt it, BUT I think the reason I tampered with my Linux settings in the first place was because I managed to run GZDoom on Intel GMA 3150 in windows 7 and figured that it must be possible under Linux as well. I may do some research concerning the drivers I use for windows etc., but it will be no sooner than at the weekend.

Share this post


Link to post
On 17/05/2014 at 1:02 PM, Patrol1985 said:

sudo apt-get install driconf

pless give a link for install driconf.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now