Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
AD_79

Disabling Screen Effects?

Recommended Posts

So, I got a quick question. Is there any way to disable screen recolor effects? (Screen turns red for a second when taking heavy damage, screen turns blindingly white after picking up an invulnerability sphere, etc.)

Share this post


Link to post

Yes, these are based on palette and colormap effects. I actually just posted something here that stops the screen from being bright red without disabling the effect entirely:
http://www.doomworld.com/vb/showthread.php?postid=1272784#post1272784

In GL ports, and any version of ZDoom, the palettes aren't used. I know GLBoom+ has an option to disable these effects, I don't know about ZDoom but I imagine there's some way of changing it.

What port(s) do you use?

Share this post


Link to post

For ZDoom you need to change the blending values used for these effects.

For other ports, you can use SLADE 3.

  • Insert the Doom PLAYPAL in a wad. (Archive->New->PLAYPAL, Doom)
  • Select the new PLAYPAL lump, and remove special effects palettes if needed. (Palettes->Remove Others. The palette added by SLADE only contains the first so this step is not needed if you do it that way.)
  • Replace the special effects palettes by identical copies of the first palette. (Palettes->Duplicate.) Repeat until there are 14 palettes total.
Save the lump, save the file, and quit. You can now load it with your port of choice (except ZDoom) and will have no visible palette swaps during the game.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×