Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Impie

Hacx & Doom Builder 2?

Recommended Posts

Yesterday I was looking forward to toying around with Hacx in DB2, only to discover that it's not listed anywhere on the configuration screen. The handful of maps available on idgames were apparently made with programs I never heard of before. Is there a trick to building Hacx maps with DB2 or am I gonna have to use a different map builder altogether?

Sorry if this question was answered elsewhere on the forums. I searched for Hacx threads and mostly got stuff relating to "hay anyone remember dis game?" and Hacx 2.0

Share this post


Link to post

The original maps were made with Doom map editors, by people who just made themselves a document telling them "mancubus are actually phages" and so on.

Share this post


Link to post

I had worked on a set of configs last year that were derived from a DECORATE lump for Hacx 1.2, that was for GZDoomBuilder but it shouldn't take long to convert them to DB2. What I don't know is how compatible they'd be with vanilla Hacx.

Share this post


Link to post
GreyGhost said:

I had worked on a set of configs last year that were derived from a DECORATE lump for Hacx 1.2, that was for GZDoomBuilder but it shouldn't take long to convert them to DB2. What I don't know is how compatible they'd be with vanilla Hacx.


I did see that thread, but I've been focusing on vanilla and general-source-port compatible maps, rather that super fancy gzdoom stuff.

Share this post


Link to post

Removing/changing port-specific features is largely a matter of using different include files, so creating a more vanilla-like config isn't a major hassle, the main difference is that I have a Hacx_things.cfg file to add to the mix.

Share this post


Link to post

Well, if you ever find the time to make it possible, I'm sure there are other members besides myself who'd be appreciative. It'd be nice to be able to mod for all the commercial doom-engine games without having to go the "every mancubus is a phage" route mentioned above.

It's not a major concern for me at the moment, though. Just an issue I was curious about.

Share this post


Link to post

OK, I assume you are talking about making PWADs for HacX, right? Like this one?

I opened a new map in DB2, in the selection I choose Doom 2, and add DOOM2.WAD and HACX.WAD as resources. So, I make a little square sector, and it strangely shows me a HacX texture instead of the normal brown, so I go to textures, and there are the HacX and the Doom 2 textures. Now, to test, I go to things, and while the monsters are still named Imp, Demon, etc, the sprites are those fom HacX, so I add a "Shotgun guy", the player start, and test. It's a HacX map (the shotgun guy is the tall white guy from HacX, and if I play with ZDoom and I select HacX as an IWAD, it plays properly.

Now, something strange. When I tested the map from DB, it used Doom2.WAD as the iwad, and it still worked, so that's weird.

EDIT: I forgot to mention that I'm using HacX 1.2.

Share this post


Link to post
Zed said:

I opened a new map in DB2, in the selection I choose Doom 2, and add DOOM2.WAD and HACX.WAD as resources.

EDIT: I forgot to mention that I'm using HacX 1.2.

Strictly speaking, you don't need DOOM2.WAD in the resource list since Hacx 1.2 is an IWAD.

Now, something strange. When I tested the map from DB, it used Doom2.WAD as the iwad, and it still worked, so that's weird.

Nothing strange about that. The wad load order will result in HACX.WAD resources replacing like-named DOOM2.WAD resources, which is pretty much everything bar some maps.

Share this post


Link to post

Heh - looks like a DoomBuilder 1.68 config, CodeImp would not be amused.

<grabs a copy for cross-referencing>

Share this post


Link to post
Impie said:

Well, if you ever find the time to make it possible, I'm sure there are other members besides myself who'd be appreciative.

Try this - it's still a work-in-progress, the config cybdmn posted helped me fill a few gaps in Hacx_things.cfg though for now I've commented out the Default Texture Sets, since they'll need a total overhaul. There's both vanilla and Boom configs, give them a test drive and let me know if you encounter any problems.

Share this post


Link to post

Maybe it's because I'm a newbie mapper, but I ran into some weirdness while developing a potential Hacx map in DB2: all the "red stone" asian textures appear to be linked as animated walls, despite the fact that they're clearly not animated in official Hacx maps (the front door of map08, for example, doesn't animate like it does on my map). Is there a trick to using only one of these textures without the wall animating?

Also thanks for messing with the config. I'll play around with it a bit.

EDIT: Well that was quick. Loaded Doom builder 2 and got this error:

Unable to load the game configuration file "Hacx_Boom.cfg". Error in file "C:/Program Files (x86)/Doom Builder 2\Configurations\Hacx_Boom.cfg" near line 234: Include missing structure 'thingflagscompare' in file 'C:\Program Files (x86)\Doom Builder 2\Configurations\Includes\Boom_misc.cfg'
Unable to load the game configuration file "Hacx.cfg". Error in file "C:/Program Files (x86)/Doom Builder 2\Configurations\Hacx.cfg" near line 209: Include missing structure 'thingflagscompare' in file 'C:\Program Files (x86)\Doom Builder 2\Configurations\Includes\Doom_misc.cfg'

Before running DB2, the two main cfg files went into the main configs directory, the two includes went into the includes directory.

Share this post


Link to post

Which release of DB2 are you using? I've not encountered any load errors with the r1715 SVN build, though that's on my old WinXP desktop. I'll see if I can replicate the problem on my Win7 laptop, since I suspect you might have encountered an access rights and/or virtual folders issue.

EDIT - You can expect to have problems with release 2.1.2.1553 from the Doom Builder website since its config files don't support that "stuck things" check.

Share this post


Link to post
GreyGhost said:

EDIT - You can expect to have problems with release 2.1.2.1553 from the Doom Builder website since its config files don't support that "stuck things" check.


Yeah that's the version I'm using. I'll try with the older one.

EDIT: Success! Success! He's done it! He's done it!

No problems so far. It's LOADS easier having everything organized and labeled, AND it solved that texture issue I mentioned before (kinda began to suspect it was related). Kind of a bummer having to clutter my comp with multiple doom builders, but maybe there'll be a fix in the future...?

Anyway thanks for taking the time to do this, man. Maybe now the community can make better use of the game's assets than the original creators did.

Share this post


Link to post
Impie said:

I'll try with the older one.

Huh? R1715 is the most recent build.

Anyway thanks for taking the time to do this, man.

You're welcome. If I can sort out a texture set config I'll post it as an update.

Share this post


Link to post
GreyGhost said:

Huh? R1715 is the most recent build.


It is? I got mine from doombuilder.com and assumed it was the most recent...

Share this post


Link to post

I'm obviously missing something. I can map for HacX in Doombuilder. The pwads load/play correctly, the textures, monsters, weapons are OK, etc. But you keep mentioning some DB builds here; why? I just wanted to know what I'm doing (or not doing) wrong, because as I understand, my "solution" isn't ideal. What's happening?

Share this post


Link to post

It's mainly for convenience, though the Hacx configs also account for height and width changes in various things.

Zed said:

But you keep mentioning some DB builds here; why?

Some changes have been made to the default configs since r1553, one of which (the "stuck things" check) caused the custom configs to fail for Impie. There's two ways to fix that - update DB2 or comment out the "thingflagscompare" calls in the configs.

Share this post


Link to post
GreyGhost said:

You can expect to have problems with release 2.1.2.1553 from the Doom Builder website since its config files don't support that "stuck things" check.

Sure enough, I updated Doom Builder 2 and now I get this message every time I run DB2:

Unable to load the game configuration file "Hacx.cfg". Error in file "C:/Program Files (x86)/Doom Builder 2\Configurations\Hacx.cfg" near line 209: Include missing structure 'thingflagscompare' in file 'C:\Program Files (x86)\Doom Builder 2\Configurations\Includes\Doom_misc.cfg'

Apparently I have an old version of DB2 on here that i long forgot about, because I'd been using my regular version for hacx stuff without any trouble. I don't get the error when I run the older version, but I'd like to know if deleting the hacx configs will make the error go away, or if it might break everything further. The message is annoying as shit.

Share this post


Link to post

That's strange, could you open Doom_misc.cfg in Notepad and confirm that the "stuck things" check is there? Should be lines 48 to 62. If it's not there, I'd say the update is either incomplete or not the r1715 build.

Share this post


Link to post

Yeah, it's not there. I don't get it, though. My normal Doom Builder was working just fine regarding Hacx stuff, until I updated.

Share this post


Link to post

The update might have failed to overwrite some files. Try this brute force approach -

  • Backup any new or modified config files, along with anything else in the Doom Builder 2 directory you don't want to lose.
  • Delete everything from the Doom Builder 2 directory.
  • Unpack the contents of Doom Builder 2 (r1715).7z to that directory.
  • Copy your backed-up config files back, overwriting existing files if necessary
That should give you a working install of Doom Builder 2 that doesn't complain about the Hacx configs.

Share this post


Link to post

I think that's sort of what I did when I got the older version and put it in its own directory. Is editing the current doombuilder's config file out of the question? To put the stuck things bit back in i mean. My first guess is no.

Share this post


Link to post
Impie said:

Is editing the current doombuilder's config file out of the question? To put the stuck things bit back in i mean. My first guess is no.

It's worth a try, here's the block of text that's missing.

// How thing flags should be compared (for the stuck thing error check)
thingflagscompare
{
	skills {
		1;
		2;
		4;
	}

	gamemodes {
		16 {
			comparemethod = "equal";
		}
	}
}

Copy/paste it into Doom_misc.cfg and see if that makes the error message go away. If not, (probably due to Builder.exe being an older release which doesn't support that function) we'll need to undo the changes to Doom_misc.cfg and delete or comment out the includes in Hacx.cfg and Hacx_Boom.cfg.

I prefer commenting out since it's not as permanent as deletion. It's just a matter of inserting a double-slash at the start of each line you want Doom Builder to ignore (as in the first example below), or a pair of slash-star comment lines (/* */) in the right places to comment out a block of text.
// thingflagscompare
// {
//	include("Includes\\Doom_misc.cfg", "thingflagscompare");
// }
// How to compare thing flags (for the stuck things error checker)
/*
thingflagscompare
{
	include("Includes\\Doom_misc.cfg", "thingflagscompare");
}
*/
The include start at line 206 in Hacx.cfg and line 232 in Hacx_Boom.cfg

Share this post


Link to post

I tried the first thing, adding that code to the cfg file for doom_misc, and now i get a single error for Hacx_Boom instead of for both Hacx versions:

Unable to load the game configuration file "Hacx_Boom.cfg". Error in file "C:/Program Files (x86)/Doom Builder 2\Configurations\Hacx_Boom.cfg" near line 234: Include missing structure 'thingflagscompare' in file 'C:\Program Files (x86)\Doom Builder 2\Configurations\Includes\Boom_misc.cfg'

Does that mean I should paste it into Boom_misc as well? Or just edit the Hacx configs like you said?

Share this post


Link to post
Impie said:

Does that mean I should paste it into Boom_misc as well?

It does, though the Boom script is different.

// How thing flags should be compared (for the stuck thing error check)
thingflagscompare
{
	skills {
		1;
		2;
		4;
	}

	gamemodes {
		16 {
			invert = true;
		}

		32 {
			invert = true;
		}

		64 {
			invert = true;
		}
	}
}

Sorry, I missed that one.

Share this post


Link to post

Sweet, no more errors. I'll post here again if any other issues come up I guess.

Thanks again for the help!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×