Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Lazer

Line_Horizon not working?

Recommended Posts

I've been revisiting a bunch of maps in attempt to finish an old project of mine and just came across a strange issue. On one of my maps there's an exit where it should appear as though the horizon extends out in front of you. I have done this before in other maps using the 9:Line_Horizon() Zdoom tag.

There's a big grassy sector surrounded to the north by another sector with the ceiling height=floor height (164). The ceiling height of the big sector is 415. Both sectors have the fsky ceiling texture and the lines (3 of them) between the 2 sectors all have the Line_Horizon tag. Everything appears to be setup properly, however when I go in-game the horizon cuts off right at the edge where the sky begins.

What could I be overlooking here? I've tried different floor/ceiling heights and flipping the directions each line faces as well as setting the sector tags to a new ID in case there was some odd effect being accidentally applied to ID 0.

Screenshots related:

Spoiler

Spoiler

Any ideas are appreciated thanks!

Share this post


Link to post

well maybe because i never tried to use line horizon property on a double linedef (gray ones). i always use 1 side lines (white ones) to use that property since well those walls wouldnt be displayed if you use the line horizon property on them.

why you dont try to use line horizon on the lines behind the ones you are using ? ( the blue ones) i mean try to use line horizon on the 1 white side lines that are behind the lines you set the property

Share this post


Link to post
Z0k said:

well maybe because i never tried to use line horizon property on a double linedef (gray ones). i always use 1 side lines (white ones) to use that property since well those walls wouldnt be displayed if you use the line horizon property on them.

why you dont try to use line horizon on the lines behind the ones you are using ? ( the blue ones) i mean try to use line horizon on the 1 white side lines that are behind the lines you set the property


Oh wow that worked. Now I'm wondering why the way I had it setup before was working on my other maps?? Oh well weird but thanks for the quick solution!

Share this post


Link to post
Lazer said:

Now I'm wondering why the way I had it setup before was working on my other maps?? Oh well weird but thanks for the quick solution!


dunno, have you tried your previous map with your current version of zdoom/gzdoom? if they display correctly then you should check your previous map and probably look into the floor heigh. thats the only thing i would do, because that line probably its on the same heigh as the floor it have behind. so maybe that its the reason why it dont display with your usual setup

so if you lower a bit the floor from the sector behind that line then maybe your line horizon probably will display (but im not so sure since i dont use line horizon in the way you use it). but hey maybe worth a shot to check it :P.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×