Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
MFG38

GZDoom rendering problems

Recommended Posts

So this is a problem I've been struggling with a few times. It would appear to only occur with wads specifically designed for GZDoom - I've never seen this happen with for example a vanilla or Boom map while playing in GZDoom.

Basically what happens is GZDoom pulls this off, as shown in the two screenshots below:

https://pbs.twimg.com/media/B4WzLgjIIAEUMI3.png
https://pbs.twimg.com/media/B4WzMLGIgAA8YZ9.png

(Also, all other sprites apart from the HUD ones stop being visible.)

Anybody know what's going on here? I get the feeling it's either a mapping trick or something in my GZDoom settings that's causing this. If anybody is able to help me, I would appreciate your input greatly.

Share this post


Link to post

This is clearly a problem with your graphics driver so you'll have to tell us at least what kind of graphics card you have.

Share this post


Link to post
Graf Zahl said:

This is clearly a problem with your graphics driver so you'll have to tell us at least what kind of graphics card you have.


GeForce GT540M, with the latest drivers installed.

Share this post


Link to post

Hm... That shouldn't cause any problems of that kind. I have a Geforce 550Ti and never saw anything similar.

Which GZDoom version is this?

Share this post


Link to post

Nope, didn't help. 1.8.07 didn't fix it, and 2.0.03 and the latest dev build both crashed upon startup.

Share this post


Link to post

There's a feature in display options menu that disables textures in GZDoom,but it replaces them with white texture,don't know if this is the problem,but check if it's enabled if so.. disable it

Share this post


Link to post
DMGUYDZ64 said:

There's a feature in display options menu that disables textures in GZDoom,but it replaces them with white texture

It doesn't replace with white texture, it disables textures entirely. So you get flat polygons. It's not white because white texels are projected onto the surface, it's white because there are no texels at all.

Share this post


Link to post
DMGUYDZ64 said:

There's a feature in display options menu that disables textures in GZDoom,but it replaces them with white texture,don't know if this is the problem,but check if it's enabled if so.. disable it


I'm 100% sure that's not the case, since I do have textures enabled in GZDoom.

Share this post


Link to post
MFG38 said:

I'm 100% sure that's not the case, since I do have textures enabled in GZDoom.

Maybe you messed up with graphics card options ...

Share this post


Link to post
VGA said:

Maybe your laptop also has an integrated shitcard?


It does, actually. That explains it then...

EDIT: Yep, there we go. Thanks for the help.

ANOTHER EDIT: Holy hell, even the framerate improved a bunch!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×