Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Evil_Ascended

Issues/Errors With Doomsday Engine

Recommended Posts

Hello Everyone,

At first, I posted this on the Dengine Forum Technical help, but nobody bothered to provide help. However, this is a much more friendly place and people here take things seriously and responsibly. Hence, I am expecting some help regarding the following Issues/Errors:

So I'm having some issues when I launch any particular WAD of Doom.

First, let me be clear on the system in which I run Doomsday:

OS: Windows XP Professional (Service Pack 2) 32-bit
Processor: Intel Core 2 Duo E8400 @ 3.0 GHz
Memory: 8GB DDR3 RAM @ 1333MHz
Available OS Memory: 3.12GB DDR3 RAM @ 1333MHz
GPU: MSI GeForce N550 GTX-TI Cyclone II OC 1GB GDDR5
DirectX Runtime Version: 9.0
Display Memory: 1024 MB
Driver Version: 306.81

Although I've downloaded the 1.14.5 version of Doomsday, but after installation, in the "readme" file it says version 1.13

Hence, after Installation, I have created a particular folder for the WADS inside the Doomsday directory, and copy pasted the wads there. IMAGE LINKS BELOW:

http://s29.postimg.org/xrd7zskxj/WAD_LOCATION.jpg

http://s22.postimg.org/n5un4dgb5/WAD_LOCATION2.jpg

These are the addons I have downloaded & put in "Snowberry/addons". IMAGE LINK BELOW:

http://s16.postimg.org/67sel74wl/Addons.jpg

1) DOOM Classic Music 2008.09.30
2) DOOM High-Quality Sound Pack 2010.01.09
3) DOOM High-Resolution Texture Project
4) DOOM High-Resolution User interface Pack 2012.02.23
5) DOOM Resource Pack (jDRP) 1.01
6) Slide's Skyboxes
7) Sycraft Remixes 4
8) TNT Lorcan Remix 2007.12.25

These are my settings Prior to launching:

http://imageupper.com/g/?S020001003A14175146781362188

First up, when I launch any Doom WAD, I am stuck at here:

http://s8.postimg.org/8b6wzv0n9/Shime_Map_Error.jpg

No matter how many times I select "shinemaps" and click "continue", I'm prompted at the same screen over & over again.

Secondly, however, when I disable the shinemaps effect, I am able to launch the WADS. But after launching, this is what I get at notifications tab:

http://s21.postimg.org/cpt9rxrkn/In_Game_ERROR1.jpg

http://s1.postimg.org/wkyryf51r/In_Game_ERROR2.jpg

Finally, although I can hear the gunfire, enemy and other sounds, no music is present.

Here's the LINK to my "doomsday.out" log:

http://pastebin.com/qRrnPTYF

Is there something I am doing wrong ?

I am not familiar with in-depth knowledge of such engines. Help in detail would be very much appreciated.

Thank You All.

Share this post


Link to post

The issues you are having are all add-on related configuration issues rather than with Doomsday itself.

The warnings in the alert log concern missing resources, which the respective add-on author has seemingly either forgotten to include or otherwise got the paths incorrect in some way.

Older versions of Doomsday did not make issues like these so obvious. Previously the add-on author had to check the log manually and otherwise ensure their mod was working correctly. However that tended not to happen reliably and subtly broken mods would often be released into the wild.

Nowadays, Doomsday makes such issues immediately obvious to try and combat the issue.

Most of the add-ons you are trying to use pre date the alert mechanism, so it is fairly likely the issues you are seeing can be ignored simply because the add-on was released in that state to begin with. Regardless of whether or not the author knew about those issues, the mod was released so they are "expected behavior". All we can really do is prompt the author(s) to release a fixed version.

Conflicting resources
I tried and failed to replicate this with the add-ons "Doom hi-res Texture Pack" 2013-08-13 and "jDoom Resource Pack (jDRP) - Packed by Harry" 1.01 Maybe some other add-on you have loaded is causing a problem.

In this situation, disable add-ons until you narrow down the root cause of the conflict.

Missing music
You appear to have loaded multiple conflicting music add-ons from several different authors. Try disabling them and see if music works.

Readme version number
Please ignore the version number in the readme file. This is one of the last tasks which we've yet to automate in our release build process. Clearly, we simply forgot to update that number.

Share this post


Link to post

Thank you very much for the info.

I will run the original PWADS and see whether the problems still persist.

On another note, if the recent builds are causing such issues, will the older versions run the PWADS with the add-ons enabled without any problems ?. If so, then which build should I use ?

Thank you.

Share this post


Link to post

As I explained, the alerts you are seeing are merely reports of long standing issues within the add-on(s) you've chosen to load. There is no issue with Doomsday. The difference between the current version and previous versions (in this context) is that issues within those add-ons will now be pointed out to the user, where previously they weren't.

If you simply want to make the alerts go away, you can configure the alert system from the task bar - look for the console button (visually similar to [=]) in the bottom left corner and click it to reveal the menu where you should find a submenu labelled "Log Filter & Alerts" - from here you can disable alerts entirely.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×