Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kapanyo

[TRIVIAL] W_CacheNumLumps: [Random number each time]

Recommended Posts

So, I know there's a very old thread about this question, but renaming F_START to FF_START hasn't solved the problem for me. (I'm mapping for Vanilla Heretic, by the way)

So, here's a screenshot:



Any ideas? Thanks in advance.

Share this post


Link to post

In my vanilla wads I put all my textures (including skies) between PP_START and PP_END. Flats go between FF_START and F_END (just one F for F_END). You don't need the P_START and P_END..

Well, this method works for me anyway.

Share this post


Link to post

Don't you mean W_CacheLumpNum? There's no such string as W_CacheNumLumps in Heretic.

The function in Heretic source code is

void	*W_CacheLumpNum (int lump, int tag)
{
byte *ptr;

	if ((unsigned)lump >= numlumps)
		I_Error ("W_CacheLumpNum: %i >= numlumps",lump);
		
	if (!lumpcache[lump])
	{	// read the lump in
//printf ("cache miss on lump %i\n",lump);
		ptr = Z_Malloc (W_LumpLength (lump), tag, &lumpcache[lump]);
		W_ReadLump (lump, lumpcache[lump]);
	}
	else
	{
//printf ("cache hit on lump %i\n",lump);
		Z_ChangeTag (lumpcache[lump],tag);
	}
	
	return lumpcache[lump];
}
So it's told to cache a lump number something, and you claim that number changes each time.

Since you're targeting vanilla Heretic, I'd like to mention that the TEXTURE1 lump is suspiciously small. The IWAD's TEXTURE1 lump is 3102 bytes, yours is merely 112 bytes. I guess it only contains your new or modified textures, leaving all the unmodified IWAD textures out. And vanilla does not like that.

SLADE 3 has the option to import the texture definition from the base resource archive precisely for this reason. You probably told it to create it empty, or you didn't set the base resource archive at all. Either way, you'll have to import the textures from the IWAD TEXTURE1 lump now.

Share this post


Link to post

I told it to create an empty one, not knowing what it meant. Ugh... man, but patches and flats sure are fiddly.

[EDIT]: Off-topic, but autocorrect just gave me the option of replacing "fiddly" with "piddly". Really.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×