Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

[BUG?] soundsequences have no vertical attenuation

Recommended Posts

Not sure if intended or not, but soundsequences with attenuation don't take z-height into account. So a sound that fades away after moving eg. 256 units away from the source is still heard at 100% volume thousands of units directly above/below it.

Share this post

Link to post

Unfortunately this is how all sounds work in Doom -- vertical distance wasn't taken into consideration at all when the game was created. It'd be great to have some way of controlling this in Eternity for portal-heavy maps, at least with an EMAPINFO flag or something.

Share this post

Link to post

Perhaps an additional flag for portals to block sounds? Right now I can hear the leaky pipe in the basement when chilling in my lofty command tower 4k units higher, and it kinda ruins the enjoyment of the panoramic view of the surrounding countryside :)

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this