Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Breeder

zandronum opengl issues

Recommended Posts

Hello, I am finally getting around to checking out Zandronum, the thing is though that after I set it to Gl mode and restart it, I don't get a display on my screen, even though the resolution I have set is one my monitor can handle.

I of course looked this up on Google, read through some threads, and re-installed Zandronum as suggested and updated my graphics card drivers, yet no matter what, this is the one game that I can not get to play correctly in GL. Even Rage and Perfected DOOM 3 run without issues.

I also decided to try it out on my Mint Linux based laptop. Well on there it says it is in GL mode, but is not, it remains in software mode and displays a lot of garbage on the screen.

Two OS' and no luck. ANy advice?

Share this post


Link to post

Check vid_fps. Some monitors suck at reporting supported refresh rates and if the engine tries to set something bogus all you get is a black screen.

Share this post


Link to post

I went into the config file and changed Full Screen to FALSE.

Then in the game I was able to try different resolutions then safely switch between full screen and window till I found one that worked.


That aside, when ever I start the game, be it in software or GL mode, I am presented with a blue and white checker board.

Share this post


Link to post

Are you using the IWAD from the BFG edition?
If yes, that one's missing the titlepic and Zandronum is based on a ZDoom version that's too old to handle this.

Share this post


Link to post
Graf Zahl said:

If yes, that one's missing the titlepic and Zandronum is based on a ZDoom version that's too old to handle this.

Moreover, he's going to need to patch it any way to play online so there's not a lot of incentive for Zandronum to support it.

Share this post


Link to post

Strictly for solo play, but yes I do believe I used the DOOM 3 iWAD so I'll use an older one and see how it goes this afternoon.

Share this post


Link to post

Even for single player the original 1.9 IWAD is recommended. Besides the gratuitous removal of the title picture, the BFG edition has some textures effectively removed as well as the Wolfenstein SS completely broken. Whether you care or not could depend, but in general everything is designed for 1.9 not BFG edition.

Share this post


Link to post
Blzut3 said:

Even for single player the original 1.9 IWAD is recommended. Besides the gratuitous removal of the title picture, the BFG edition has some textures effectively removed as well as the Wolfenstein SS completely broken. Whether you care or not could depend, but in general everything is designed for 1.9 not BFG edition.


And 1.9 works without problem, thank you!

Share this post


Link to post

Any ideas how to get this in GL mode under Linux? I only resolved my Windows issues. :)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×