Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kotzugi

*sigh* Doom2 demos desync

Recommended Posts

Out of respect for those posting on the Doom 2 demo thread I'm starting my own. I hope somebody can help me. I can play ZeroMaster's lv14-014 demo but the lv02-032 desyncs. I'm using PrBoom+ 2.5.1.3 and I'm running my command from Winbash as follows:

prboom-plus -iwad DOOM2.WAD -playdemo demos/doom2/lv02-232

I have both DOOM2.WAD and DOOM2.EXE in the current directory. I'm not actually that much clued up regarding the different versions - I don't know which version I'm playing, I've had it since forever, and I don't know how to check.

Doesn't work if I add something like -complevel 2. It happens to most other Doom2 demos as well.

PS I'm going to bed here in South Africa. In the morning, I should be able to respond again. Thanks.

Share this post


Link to post

Well, most likely you have an older version of DOOM2.WAD. You can update it with this IWAD patcher for example (put DOOM2.WAD in its folder, then run it). You need the version 1.9.

Share this post


Link to post

Make sure that you have both DOOM2.WAD v1.9, and DOOM2.EXE v1.9 (if you're using the exe to play demos; not necessary if you use PrBoom-plus).

Share this post


Link to post

Yay it worked! I had v. 1.666, which was updated.

Saw something interesting, the first shotgun guy in Doom 2 Map 2 at the first button had vertical bars in front of him in the old version but not in the new version. Perhaps I should replay the IWAD, I might see some interesting changes...! Or perhaps just watch ZeroMaster's or Looper's runs, but they're gonna be too fast for me to notice anything, hehe.

Cheers Memfis I owe you a couple of beers or something :)

Thanks scifista will keep in mind, although I do use PrBoom+ so I guess it's not strictly necessary to patch the .exe as well as you say. But what about when I play with other ports?

Share this post


Link to post
Kotzugi said:

But what about when I play with other ports?

You don't need to have the EXE at all if you're using ports. All modern ports are originally based off the Doom's v1.9 EXE (or off other ports). Demos might still desync between demo incompatible ports - for example between the ZDoom family and other ports, or even various ZDoom versions between each other.

Share this post


Link to post
Kotzugi said:

I'm not actually that much clued up regarding the different versions - I don't know which version I'm playing, I've had it since forever, and I don't know how to check.

Versions of Doom and Doom II
DOOM2.WAD
DOOM2.EXE

Kotzugi said:

Saw something interesting, the first shotgun guy in Doom 2 Map 2 at the first button had vertical bars in front of him in the old version but not in the new version. Perhaps I should replay the IWAD, I might see some interesting changes...!

That's the only visible change between the two versions.

Kotzugi said:

although I do use PrBoom+ so I guess it's not strictly necessary to patch the .exe as well as you say. But what about when I play with other ports?

Ports don't use DOOM2.EXE in any way.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×