Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Calibrating prBoom mouse sensitivity to ZDoom settings.

Recommended Posts

I've been having trouble with this. ZDoom feels perfect, but I move sluggishly and haphazardly in prBoom, constantly running into walls in an unpredictable and frustrating manner (as opposed to constantly running into walls in a manageable way, heh).

I use the mouse to turn left and right and to shoot, nothing else. I have the latest versions of both ports.

Lines that look mouse-relevant from my ZDoom config:


Likewise from prBoom:

# Mouse settings
use_mouse 1
mouse_sensitivity_horiz 12
mouse_sensitivity_vert 0
mouseb_fire 0
mouseb_strafe -1
mouseb_forward -1
mouseb_backward -1
mouseb_use -1

(I've been playing around with various horizontal sensitivities, but none of them are right at all.)

# Prboom-plus mouse settings
mouse_acceleration 0
mouse_sensitivity_mlook 0
mouse_doubleclick_as_use 1

movement_mouselook 0
movement_maxviewpitch 90
movement_mouseinvert 0

Whenever I get the mouse sensitivity to a base level that seems right in prBoom for most motions, I end up with the ability to whip completely around unnaturally fast at the slightest over-push of the mouse. That never happens with my ZDoom settings, which seem to impose a ceiling on my mouse speed.

Share this post

Link to post

AFAIK, the mouse in PrBoom is affected by the Windows settings. If you have "enhance pointer precision" turned on, try turning it off while playing.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this