Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Lightning Hunter

The Dying End problem.

Recommended Posts

I am trying to play through "The Dying End" by Christopher Lutz, but can't get passed the part shown in the screenshots. This is the first time I've ever gotten stuck in a user-made map, which tells me it might be a bug. The area in question has a lava pit with a bridge that is supposed to rise. There are revenants on the other side of the lava pit, and a pain elemental in front of a switch down in the pit. I noticed I can push the switch 3-4 times, but then nothing else happens. The bridge does not rise any further than shown below. Thus, I can't escape the lava pit. This happens in Risen3d, Zdoom, and PrBoom (I tested this area in all 3 ports). Am I missing something?






Find the map here:
http://www.doomworld.com/idgames/index.php?file=levels/doom2/Ports/s-u/tde-lutz.zip

Share this post


Link to post

No, that's definitely a malfunction. Looks like the marble walkway is stopping at the same height as its metal border, the whole thing is supposed to build with a single switchpress, trim first, then pathway.

I'm afraid I can't tell you what compatibility tweak is fucking it up for you, though. It functions as intended for me in Eternity, prBoom-plus at the textfile-specified complevels (9 and 11, e.g. Boom and MBF), and a rather old version of ZDoom (2.7.9-something). Risen3D tends to be rather buggy with this kind of stuff as a generality. If by "PrBoom" you literally meant PrBoom at default complevel, and not PrBoom-plus at default complevel, you're likely running into a complevel conflict. As far as your copy of ZDoom not liking it I really don't know what to tell you, I'm afraid.

Share this post


Link to post

What is supposed to happen? Is the switch supposed to make the bridge rise to the level of the two marble platforms? If so, then I might just modify the map on my end to make it compatible with Risen3d...

Share this post


Link to post
Demon of the Well said:

Yes, the switchpress is supposed to raise the marble walkway to the same height as the marble platforms with green torches.

Correct. There are actually 4 pass-through switch lines stacked up with 1-unit spacing, three of which are "S1 RAISE FLOOR TO NEXT HIGHEST FLOOR" actions that affect the trim, walkway, and walkway-under-hanging-lights sectors, respectively. All of these sectors have dummy geometry off of the map that control how high the sectors are supposed to raise.

I suspect that the engine you are using is using the trim sector as the "NEXT HIGHEST FLOOR" height of the walkway sector; I suppose one could start a philosophical discussion on what constitutes "NEXT HIGHEST" when two adjacent sectors are in motion, but it worked for me in ZDoom and MBF, so I went with it.

Share this post


Link to post
Lutz said:

Correct. There are actually 4 pass-through switch lines stacked up with 1-unit spacing, three of which are "S1 RAISE FLOOR TO NEXT HIGHEST FLOOR" actions that affect the trim, walkway, and walkway-under-hanging-lights sectors, respectively. All of these sectors have dummy geometry off of the map that control how high the sectors are supposed to raise.

I suspect that the engine you are using is using the trim sector as the "NEXT HIGHEST FLOOR" height of the walkway sector; I suppose one could start a philosophical discussion on what constitutes "NEXT HIGHEST" when two adjacent sectors are in motion, but it worked for me in ZDoom and MBF, so I went with it.


Something must have changed in the Zdoom engine along the way, because the version I'm using - 2.1.4 - has the same problem as the screenshot above. The bridge does not go all the way up, no matter how many times I push the switch. The version of Zdoom you used back then to test it must have behaved differently.

Share this post


Link to post

ZDoom 2.1.4? That seems rather old. Even Zandronum is based off of 2.5.0

Have you tried the latest ZDoom dev build? It is based off of 2.8.0.

http://devbuilds.drdteam.org/zdoom/

Switch functions in a 2.8 based dev build from no clipping straight to said switch and pressing it. Perhaps a previous action glitches it?

Share this post


Link to post

Works fine for me with the latest GZDoom build.

ZDoom 2.1.4 is very old, don't use that. I remember that several years ago ZDoom had problems with the passthrough flag from Boom and some stuff in Phobos:Anomaly Reborn had similar problems.

The problem here is that if the switches are not triggered simultaneously the floors won't find their proper target height so not hitting them all will definitely break the map.

Share this post


Link to post

Good to know. I'll update my copy of Zdoom. I never bothered before, because Zdoom is not my engine of choice. I pretty much use it for testing purposes only.

By the way Graf, I've seen a lot of your comments on IDgames after mine. :)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×