Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
AwesomeO-789

Exit Text Aligns To The Right Of The Screen

Recommended Posts

UPDATE: FIXED






So I'm working on a wad that has a lot of story in the form of exit text. Every mission there's an exit text screen after (I plan to make it only 8 levels long so it won't be too tedious) so it's pretty important I get it working properly. Here's the issue I'm having:

Whenever I create an exit text through a zdoom MAPINFO (using Slade 3 btw) it always "aligns" to the bottom right of the screen. Not the very bottom, but it doesn't start at the top like a normal exit text screen would. It also doesn't start at the left and is closer to the right of the screen. Here's a screenshot:



Because of the issue if I write exit text like I assume you'd normally do in a MAPINFO file, most of the text is off screen.


ADDITIONAL INFO:

iWAD: Doom II
Map Editor: Doom Builder
WAD Editor: Slade 3
Doom Builder config: Zdoom (Doom in Hexen)
Source Port: GZDoom

If anyone could help it'd be much appreciated. I may not be able to try out your solutions straight away but please leave them here anyway.

Share this post


Link to post

There is a point where there is simply too much text to show on the screen. Remember that some players will be using lower resolutions, further reducing the space to show text. I would recommend shortening it to fit on the screen better. Also, if this is the text you're using, you might want to proof-read it a little more. Remember, Doom is a game about action, not reading, so try to keep your text to a minimum!

If you simply must have all of your text, you might be able to set up some fancy ACS scripts at the start or end of your levels and have them display text in a similar fashion (but if you choose this route, please allow the player to skip it if they want to, and don't use that tiny default font).

Having said all of that, there might be a way to achieve the effect you want, but sadly, I don't know how (or if there is one). Anyways, best of luck finding a solution to your answer, and hopefully someone with more knowledge than me will come along and point you in the right direction!

Share this post


Link to post
Surreily said:

There is a point where there is simply too much text to show on the screen. Remember that some players will be using lower resolutions, further reducing the space to show text. I would recommend shortening it to fit on the screen better. Also, if this is the text you're using, you might want to proof-read it a little more. Remember, Doom is a game about action, not reading, so try to keep your text to a minimum!

If you simply must have all of your text, you might be able to set up some fancy ACS scripts at the start or end of your levels and have them display text in a similar fashion (but if you choose this route, please allow the player to skip it if they want to, and don't use that tiny default font).

Having said all of that, there might be a way to achieve the effect you want, but sadly, I don't know how (or if there is one). Anyways, best of luck finding a solution to your answer, and hopefully someone with more knowledge than me will come along and point you in the right direction!


I don't think you quite understood what I was asking help on. Compare my screen to a normal Doom 2 text screen and you can tell something isn't right. The usual doom 2 screen aligns to the left while mine aligns to the right. If mine aligned to the left like normal I could fit all my text there.

btw thanks for the advice, keep in mind what I posted was a rough draft and the only reason I posted it was I needed it for this thread.

Share this post


Link to post

You must set the newlines manually, by putting \n wherever you want the newline to be. You can use spaces to "offset" the beginnings of lines.

Share this post


Link to post
scifista42 said:

You must set the newlines manually, by putting \n wherever you want the newline to be. You can use spaces to "offset" the beginnings of lines.


Didn't work. Thanks anyways.

Share this post


Link to post

Keep the newlines anyway, because maybe the lines of your text are wider than Doom's native 320 pixels and that's why your source port chooses to auto-align the whole text.

Check out MAPINFO/GameInfo_definition - "textscreenx" and "textscreeny" options. Play with them and maybe it will help.

Also, I recommend you to test the appearance of your texts in ZDoom and Zandronum too, maybe they will be different (or depending on screen resolution).

Share this post


Link to post

To set newlines within a ZMAPINFO definition, you need to have each line be its own string, e.g.

exittext = "this is the first line", "this is the second line", "third line now", "", "new paragraph";

Share this post


Link to post

Look, I really appreciate your guys' help, but is there anyway you can dumb down the explanation a little for me? I haven't been mapping for some number of years, and even then I knew little of it. The way you guys are explaining it to me feels like you're talking about something completely different to what I'm doing;



Sorry if I'm a pain to work with, I just want to ensure I can make my map as good as it can be.

Share this post


Link to post

Nevermind, I'm sorry for bumping this thread again. I managed to fix it after looking a bit more for a solution, thanks for the help anyway guys! Much appreciated!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×