Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
odysseyofnoises

Demo desyncing on my map

Recommended Posts

I finished building map04 of my wad, but when I tried recording demos for it, they always desync in one particular area, and I have tried everything but haven't been able to fix it. When it happens, the player and projectiles seem to noclip through walls. Since it appears I can't attach files here, I have a link to a zip file with the wad and an example demo. The demo desynches at like 2:15.

http://speedy.sh/gnpQV/map04.zip

Share this post


Link to post

Any particular port I should look at this with?

Edit:
Played back fine using Eternity (quitting after you use the teleporter soon after killing the not-Cyberdemon). What you're describing though sounds like a SpecHits Overflow.

Edit 2:
PrBoom also played the demo without error. Which port are you having issues with?

Share this post


Link to post

Sounds more like an intercepts overflow to me. Those are what generally cause the "all-ghosts" bug being described above.

Share this post


Link to post

Oh, yeah, I probably should have mentioned that the demo desynches for me in prboom-plus. The demo should show me exiting after killing the modded cyberdemon. That is really weird that it played back for you.

**EDIT**: The demo plays back fine for me in prboom-plus, but not glboom-plus, which is what I was actually using before. I think I'm going to check and see if there's a setting I manipulated that is causing this. I vaguely remember changing some sort of compatibility option involving spechits or intercepts or whatnot to play back a demo like a year ago...

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×