Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
rdwpa

*** The "ask a miscellaneous editing question" thread ***

Recommended Posts

Make sure SKY3 is still defined. You may not be using the texture explicitly, but PRBoom+ is still expecting it to exist.

Share this post


Link to post

So i did what you say but instead of fixing it showed f×cking signal 11 error. F×ck this texture pack :/

Share this post


Link to post
4 hours ago, Kappes Buur said:

 

That is not surprising, since PRBoom+ can only use the resources of the original DOOM.

The fix is to use GZDoom to have the DECORATE lump recognized.

Well the problem is, I am using PRBoom+ for testing how my mod's sprites work in game.

And I AM using the original Doom sprite format + the game went fine when I have replaced all 32 movement sprites of the Cyb and its FaceTarget/Shoot sprite, but when I put in its pain rotation sprites + its death sprites, PRBoom+ instantly gave me that error.

Edited by TheNoob_Gamer

Share this post


Link to post
18 minutes ago, Marlamir said:

So i did what you say but instead of fixing it showed f×cking signal 11 error. F×ck this texture pack :/

 

 

Share this post


Link to post

Hey, quick question on brightness levels for Boom format: From what I've read, 8bit Software mode only displays light levels which are multiples of 16, such as the ones you can cycle through by default in Doom Builder. Meanwhile OpenGL can show all the different brightness levels. Is there any reason to bother with, say gradients of 4 brightness unless I'm specifically targeting OpenGL?

Share this post


Link to post

Thank alot Edward for the link, didn't know choosing "import from base resourece archive" instead of "create new" will actually fix this. F×cking prboom and his bugs. Thank again

Share this post


Link to post
15 minutes ago, Marlamir said:

Thank alot Edward for the link, didn't know choosing "import from base resourece archive" instead of "create new" will actually fix this. F×cking prboom and his bugs. Thank again

These aren't bugs per say. TEXTURE1/2 and pnames aren't stackable lumps; when you define a new one it essentially replaces the original rather than adding to it. The bug here is more PRBoom+ doesn't handle missing definitions particularly gracefully.

Share this post


Link to post
4 hours ago, Marlamir said:

Thank alot Edward for the link, didn't know choosing "import from base resourece archive" instead of "create new" will actually fix this. F×cking prboom and his bugs. Thank again

 

I've had also problems with the same thing! Propably the next problem will be with custom animated textures if you run Slades "archive maintenance" things (remove unused textures/patches..). You have to include all the animation frames in one of the maps, otherwise they will be deleted and you will have ridiculous slideshow effect on all textures.

Share this post


Link to post
14 hours ago, Jaska said:

 

I've had also problems with the same thing! Propably the next problem will be with custom animated textures if you run Slades "archive maintenance" things (remove unused textures/patches..). You have to include all the animation frames in one of the maps, otherwise they will be deleted and you will have ridiculous slideshow effect on all textures.

I have that problem just few months back. It actually took me a while to realize why the waterfall texture are no longer animated :D

Share this post


Link to post

Yeah, the vanilla anims and switches are hardcoded in that check but actually handling custom ANIMATED/ANIMDEFS/SWITCHES lumps to dynamically build a list of textures to preserve has been a very procrastinated TODO item. Gotta handle the various MAPINFO derivatives to make sure not to delete sky textures. Oh, and what about scripts that dynamically change textures, gotta check ACS and FraggleScript too...

 

So yeah, instead you get shown a list of apparently-unused textures and it's your responsibility to go through them and uncheck those you want to keep. Putting them on little dummy sectors does seem like a good solution to make everyone's life simpler.

Share this post


Link to post

Those dummy sectors seems like really good solution to this. Anyway i have issue to make new switches work on prboom ,in gzdoom they work without problem but in prboom not just new but even doom2 one doesnt changing texture and don't play sound yet they are activated since is does perform action. I add boom switch lump through slade and add new switch to the lump than i tried all 3 types(registered etc), compiles SWANTBLS and compile back to switch lump while deleting the old one and keep the new one. I even find SWANTBLS.exe on idgames yet it doesn't seems like to work since it crash right on start(maybe i missing something?) What do i missing please?

Share this post


Link to post

I think I know the answer but I just want to double-check. Is there any conceivable way of using a 3D floor as a polyobject? I realize 3D floors use sectors, and polyobjects use void space, I just didn't if some mad scientist had ever jimmy rigged such a thing and how they did it. 

Share this post


Link to post
On mercredi 23 octobre 2019 at 9:20 PM, Marlamir said:

I even find SWANTBLS.exe on idgames yet it doesn't seems like to work since it crash right on start(maybe i missing something?)

It's a command-line program, so if you just click on it, it runs once, prints a message about wanting command parameters, exits, and then Windows close it since it has quit. So you just see very briefly a terminal window that instantly disappears, and it can indeed look like a crash.

 

But you shouldn't need it anyway; its functionality is integrated in SLADE. I don't know why it fails in PrBoom; perhaps you're using a vanilla Doom complevel and it disables them? If that's not it, I have no idea.

 

5 minutes ago, RonnieJamesDiner said:

I think I know the answer but I just want to double-check. Is there any conceivable way of using a 3D floor as a polyobject?

Not in GZDoom, no. You can sorta work around that with portals -- putting portal effects on a polyobject's side allows you to dynamically transport a part of the level, so you can put a 3D floor inside the portaled area. The big problem here is that the portal will cover the entire space of the polyobject, from floor to ceiling. So if you use that just to travel a platform around, the effect will be damaged by being able to see the floor and ceiling textures moving with the 3D floor... (You can still work around that if you use the sky, or a featureless texture like solid black. But meh.)

 

Something you can do is set your polyobject to be made of 2D-sided 3D midtextures. This will allow to walk above and below. However, the polyobject will not have floor and ceiling textures. You'll have to fake that by having a model that you move along the polyobject. At this point you can as well just use a model without a polyobject. Gooberman experimented with this kind of things, so see these tech demos:

Alternatively, Sonic Robo Blast 2 can do 3D polyobjects. The only problem is that it only supports  its own Sonic fangame, so you can't make use of that feature in a Doom level.

Share this post


Link to post

Hmm, those demos are intriguing to say the least. I considered the idea of using models, but when it comes to collision I just don't think what I'm trying to pull off would actually work, save for engineering some sort of elaborate system of "invisible" methods of collision which managed to stay perfectly coordinated with the models. Bah, I'm just going to re-think the room, lol. Thanks for the speedy information though, gez.

Share this post


Link to post

I want the player to start with every weapon (specifically the Hexen classes).

This is the code I wrote in Decorate:

ACTOR FighterPlayer : PlayerPawn
{
	 Player.StartItem "FWeapAxe"
	 Player.StartItem "FWeapHammer"
	 Player.StartItem "FWeapQuietus"
}

but it's not working, what am I doing wrong here?

Share this post


Link to post
1 hour ago, Rince-wind said:

I want the player to start with every weapon (specifically the Hexen classes).

This is the code I wrote in Decorate:


ACTOR FighterPlayer : PlayerPawn
{
	 Player.StartItem "FWeapAxe"
	 Player.StartItem "FWeapHammer"
	 Player.StartItem "FWeapQuietus"
}

but it's not working, what am I doing wrong here?

Are you sure that your FighterPlayer is being selected as the player class?

Share this post


Link to post
52 minutes ago, Tartlman said:

Are you sure that your FighterPlayer is being selected as the player class?

 

I don't quite understand what you mean

Share this post


Link to post
2 hours ago, Rince-wind said:

I want the player to start with every weapon (specifically the Hexen classes).

This is the code I wrote in Decorate:


ACTOR FighterPlayer : PlayerPawn
{
	 Player.StartItem "FWeapAxe"
	 Player.StartItem "FWeapHammer"
	 Player.StartItem "FWeapQuietus"
}

but it's not working, what am I doing wrong here?

You're trying to redefine an already defined actor, the game will not let you do that. Worse, even if it worked, you'd be overriding the fighter player with one that's just like the default player pawn, which would make it a non-functional player class.

 

Start by changing that first line to something like "Actor RincewindFighterPlayer : FighterPlayer", you'll at least get a working player class. Should probably add back the Player.StartItem "FWeapFist", too, since I think when you redefine startitems, it's like when you redefine dropitems, the list from the parent actor is cleared first.

 

The next step is to make sure that it's your custom variant that's selected, and not the vanilla original. For that, you'll have to make a MAPINFO/GameInfo.

Share this post


Link to post

@Gez

I've done what you said and here's the mapinfo code

gameinfo
{
	playerclasses = "NewFighterPlayer"
}

 

but now I get this if I try to run the game:

Missing displayname for player class 'NewFighterPlayer'

Share this post


Link to post

Well then, add something like Player.DisplayName "Fighter" to the code.

Share this post


Link to post

Things like drawing ellipses, stair builder, bisecting lines, curving linedefs, etc. Anything that doesn't have you drawing FROM a grid point.

 

Share this post


Link to post
11 hours ago, Gez said:

Well then, add something like Player.DisplayName "Fighter" to the code.

 

I've finally made it work, here's what it looks like:

gameinfo
{
	playerclasses = "NewFighterPlayer", "NewClericPlayer", "NewMagePlayer"
}

ACTOR NewFighterPlayer : FighterPlayer
{
	 Player.DisplayName "Fighter"
	 Player.StartItem "FWeapFist"
	 Player.StartItem "FWeapAxe"
	 Player.StartItem "FWeapHammer"
	 Player.StartItem "FWeapQuietus"
}

ACTOR NewClericPlayer : ClericPlayer
{
	 Player.DisplayName "Cleric"
	 Player.StartItem "CWeapMace"
	 Player.StartItem "CWeapStaff"
	 Player.StartItem "CWeapFlame"
	 Player.StartItem "CWeapWraithverge"
}

ACTOR NewMagePlayer : MagePlayer
{
	 Player.DisplayName "Mage"
	 Player.StartItem "MWeapWand"
	 Player.StartItem "MWeapFrost"
	 Player.StartItem "MWeapLightning"
	 Player.StartItem "MWeapBloodscourge"
}

Thanks for your patience!

Share this post


Link to post
10 hours ago, LSD_Polyphony said:

What are these errors and how can I remedy them?

asdfasdf.PNG

They are not actual error, and you can stop being bothered by them if you untick the "check off-grid vertices" box.

Share this post


Link to post

I have a simple question and its probably a dumb one but i would like to know if you can make a bullet puff that spawns an explosion(actor)

and if so how could i do it in decorate

Share this post


Link to post

Is there anyway to make the Cyberdemon and Spidermastermind vulnerable to explosions (radius damage) in PRBoom compatible projects? I'm using Whacked with .BEX format, by the way.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×