Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
baja blast rd.

*** The "ask a miscellaneous editing question" thread ***

Recommended Posts

Again, the statement still stands.

You've provided no inforation that would assist anyone with helping you - What editor? What engine is the map intended for? What specs is your computer (could be a rendering issue)? How large is 'very big maps'? Are there any bugs in the map? Does this error appear in-game? Does this happen every time you make a map to a certain size / can you accurately re-create this issue every time you try?

Supply the WAD (or screenshots / videos of your issue) and as much information as possible. As it stands, saying 'I got black textures help' isn't helping us, so we can't help you.

Share this post


Link to post

From my experience, (GZ)Doom Builder's visual mode doesn't always work well with big sectors. If you're viewing a boundary of 2 sectors, at least one of which is large, it may render a black wall there. It's just a problem of the editor's visual mode renderer, it doesn't affect the map's structure in any way. I doubt it can be fixed (though maybe the situation in your particular map can be improved via messing with the "view distance" or other parameters in the editor's "Preferences"?), unless it already was fixed in the latest GZDB, so updating to its latest version couldn't hurt.

Share this post


Link to post

aa.PNG.a68844c4538d9551786da49758454279.PNG

 

Image above shows flooring details in the editor...

 

Nyt5Ws2.jpg.b52731892a0db334ed8265ff993ad76e.jpg

 

In game, the top floor texture completely covers the detailing under it. Anyone got any idea what's going on here?

 

Using GZDoom Builder (Bugfix) R2979, also GZDoom 2.4.0 for testing.

Share this post


Link to post

What are the floor heights of the main floor sector and of the sectors of the middle structure?

You aren't running the game with an older version of the wad than the one you're editing now, right?

Share this post


Link to post

Floor is lowered into the ground and the lower sidedefs remain untextured? That or you have a 3D floor / floor transfer in place, but it looks like your sectors are untagged so this is unlikely.

 

EDIT - to help us, show the same area in the editor's 3D view please, or post a copy of the wad. :)

Share this post


Link to post

Ok, never mind. Apparently using the ASHWALL2 texture is what was causing the issue, for whatever reason. 

 

Edited by A2Rob

Share this post


Link to post

So it's probably an OpenGL renderer thing (collisions with the structure work as if the structure existed and was just invisible, right?). Check if the linedefs around the center structure have any extraordinary flags (they should have "double-sided" checked and other flags unchecked). Try moving vertices around randomly in case this was somehow a GL node builder problem.

Share this post


Link to post

Need to find a way to make monster deaths launch scripts, it has to be different from each type like imps run script 1 when they die and cacodemons runs script 2 when they die...
This has to be after they are spawned from like Thing_Spawn...

Share this post


Link to post
13 minutes ago, Lowerdark said:

Need to find a way to make monster deaths launch scripts, it has to be different from each type like imps run script 1 when they die and cacodemons runs script 2 when they die...
This has to be after they are spawned from like Thing_Spawn...

Check the script 1 in this:

 

You spawn the thing, give it an unique ID, then do a Thing_SetSpecial.

You might want or not want to use Script_ExecuteAlways instead of plain Script_Execute. The difference is that if you kill two creatures at the same time, ExecuteAlways will run the script twice, and Execute will only run it once.

Share this post


Link to post
25 minutes ago, Albertoni said:

You might want or not want to use Script_ExecuteAlways instead of plain Script_Execute. The difference is that if you kill two creatures at the same time, ExecuteAlways will run the script twice, and Execute will only run it once.

When triggering scripts on monster deaths, use ExecuteAlways as a default option unless you have good reason not to! :)

 

I had a map in skulldash that was possible to get softlocked in due to it waiting on a counter to rise based on monster deaths - if you killed two at the same time with the RL, then you were screwed as it rendered the map incompleteable. :p

Share this post


Link to post
1 hour ago, Albertoni said:

Check the script 1 in this:

 

You spawn the thing, give it an unique ID, then do a Thing_SetSpecial.

You might want or not want to use Script_ExecuteAlways instead of plain Script_Execute. The difference is that if you kill two creatures at the same time, ExecuteAlways will run the script twice, and Execute will only run it once.

wow exactly the thing i was looking for, was also trying to make an idle system like you already made.

Share this post


Link to post
27 minutes ago, Lowerdark said:

wow exactly the thing i was looking for, was also trying to make an idle system like you already made.

When you're done with your project, I'd appreciate if you let me know!

Share this post


Link to post
19 hours ago, Albertoni said:

When you're done with your project, I'd appreciate if you let me know!

hmm you gonna keep working on ur project? i want to make a more "infinite" system and maybe where the player also can go around and shoot...

Share this post


Link to post
56 minutes ago, Lowerdark said:

hmm you gonna keep working on ur project?

Mine is done, it was intended to be just an April Fools joke. Feel free to use anything you want out of mine and make something serious out of it.

Share this post


Link to post

I have a map that is about >75% done layout/gameplay wise, but most areas aren't completely detailed yet. Can I upload a beta version when the gameplay is at 100%, so I can get feedback on that before I go and add detail sectors everywhere?

Share this post


Link to post

Of course, both here or as a thread in Wads and Mods. Just follow the three golden rules:

 

1- Add screenshots; Sure, the detail isn't done, but post the areas with more potential for looking amazing.

2- Don't use some weird hosting in Russian to upload your wad or something

3- Mark it as beta in the title, you can edit it out later

Share this post


Link to post

I'm trying to replace the SuperShotgun with the Coach Gun from realm 667 (http://www.realm667.com/index.php/en/armory-mainmenu-157-97317/doom-style-mainmenu-158-94349#preview-17) and I'm having a problem with it. I've already replaced a few other guns and most of them seem to work. I'm also having problems trying to replace the Rocket Launcher with the Flak Cannon from realm667.

I've had luck with the other weapons replacements, but these two are giving me grief. I'm not sure what I'm doing wrong.

These don't work:

ACTOR FlakCannon : Weapon replaces RocketLauncher
ACTOR Coachgun : Weapon Replaces SuperShotgun

but these do:
actor Autogun : Weapon replaces Chaingun
ACTOR EgoSmasher : Weapon Replaces Shotgun
ACTOR SwarmPG : Weapon replaces PlasmaRifle

 

I have Weapon.slotnumber set to the right numbers, but I can't summon, give or idkfa those two.

What gives?

Here is the file. The weapons are toward the top of the DECORATE lump.
http://www.mediafire.com/file/rbmrrhb8qj92b4a/backup.zip

If textures are important use cc4-tex

Share this post


Link to post

The file you provided doesn't have the code for these two guns, heh. I think the problem may be located between the keyboard and chair in this case. ;)

Share this post


Link to post

Here's the thing....

I got all the weapons and sprites loaded up and decided to make a backup before I started editing the DECORATE. Then I tested the backup while I was editing the original file. I haven't even tried it yet, but I'm thinking it's going to work.

Thanks. Geez

Share this post


Link to post

I don't understand,  why when I try convert main Doom 2 resources in Ancient Alien pallette (I followed text file) and they still glitches and everything turns into colourful mess. Maybe, someone could tell how they manage convert main Doom resources in other type of pallette. 

Share this post


Link to post

I have a problem. I am running ZDOOM on Ubuntu, and everything works / looks just fine, except one small issue:

 

Moving in any *one* direction starts fine but then becomes jagged and slow. However, moving diagonally (i.e., with two directional keys pressed) works just fine. This is a bizarre compatibility issue and I'm sure it has something to do with Ubuntu (latest edition).

 

Does anybody have any advice for this? Have you ever faced a similar problem while playing ZDOOM on Ubuntu?

Share this post


Link to post
3 hours ago, MysteriousHaruko said:

I don't understand,  why when I try convert main Doom 2 resources in Ancient Alien pallette (I followed text file) and they still glitches and everything turns into colourful mess.

In the Slade graphics coversion screen select the palettes as:

 

Current: DOOM (< From Doom2 patches)
Converted: Existing/Global (< To the current wad's palette. The Doom2 patches to be converted should be in the same wad with the new texture palette)

 

Also in the main window from right-upper corner try set the palette as: Existing/Global.
 

Share this post


Link to post

Is there a way to make a door open by lowering the door sector's floor? I can't seem to find anything in doom builder that will do this. I know it can be done using Floor Lower to Lowest (action 21), but I want the sound effect that doors use.

Share this post


Link to post

You have two possibilities here:

- either replace the platform sound with the door sound;

- or use an advanced port (Eternity or GZDoom)

Share this post


Link to post

Maybe you could use a dummy sector really close to the position in the map where the door is and try to time it just right. There'd probably be a little bit of a delay. This would work for Boom. It's hacky, but outside of what @gez said, I can't think of another way.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×