Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Ganryu

Movement in view mode in Doom Builder is acting up

Recommended Posts

For some reason movement in visual mode feels like it snaps to a grid, and a VERY large grid. I'm pretty sure it wasn't like this a week ago.

It seems to have been an incremental problem as a few days ago it was a bit snappy but not as much as it is now. I cannot do any precision work at all.

The smallest possible movement step I can make is 76 points in the coordinate system.

Share this post


Link to post

Try to check your keyboard drivers (if they exist), May be problem, or check your keyboard, or update the DB2 like maxed said. Good luck!

Share this post


Link to post

Will try rebooting soon.

I already have the latest version of DB2.

I also have an older version of the program installed in another directory and I when I try in that I do not have this issue. For other reasons, however, I would prefer to stick to the latest version.

riki2321 said:

Try to check your keyboard drivers (if they exist), May be problem, or check your keyboard, or update the DB2 like maxed said. Good luck!


It cannot possibly be the keyboard or the keyboard drivers because I do not have this issue in the older version of Doom Builder 2.

This problem has appeared gradually, but I wasn't really certain of it actually happening today.

Share this post


Link to post

It's a common problem: Movement in visual mode gradually becomes more and more erratic... Until you reboot your PC, and then it becomes fluid again - and the cycle continues.

Share this post


Link to post

I did totally not know that! Sounds like some kind of rounding error? Perhaps some problematic float somewhere?

Share this post


Link to post
Ganryu said:

I did totally not know that! Sounds like some kind of rounding error? Perhaps some problematic float somewhere?

We all make errors, Next time you'll know what's wrong!

Yes, i think it's a problematic float, but i don't even use visual mode, unless i'm setting textures or raising sectors, You should use the updated version of DB2, as others are not stable. Good day!

Share this post


Link to post

From what I've heard, this is related to some system internal clock thingy, which is used for calculations in Doom Builder. When you boot your PC it starts increasing, and the larger it gets the more imprecise these calculations get, hence various problems appear. When you reboot your PC that clock gets reset and it's all good again for a while. Something like that.

Share this post


Link to post

Just rebooting never worked for me. If there are people lurking in this thread that are having the same issue just try holding down the "emergency shut down" button on your laptop, if that's what you're using.

Share this post


Link to post
AwesomeO-789 said:

Just rebooting never worked for me.

Are you sure that you actually rebooted the computer, and not just put it to hibernation/sleep mode and then recover it? Only an actual reboot works.

Share this post


Link to post
scifista42 said:

Are you sure that you actually rebooted the computer, and not just put it to hibernation/sleep mode and then recover it? Only an actual reboot works.


Yeah man, I tried the "Shut Down" and "Restart" options on the start menu and would sometimes wait a good hour or so to make sure it was actually shut down but it never worked.

Share this post


Link to post

I know it doesn't answer your question (which by the way, rebooting worked for me when using DB2), but unless there is any reason you shouldn't, you really ought to try GZDoomBuilder - basically DB but with more support for other formats and some handier editing tweaks =]

I am a convert!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×