Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Guest Deathman

Prboom music problem

Recommended Posts

Guest Deathman

Where can I get the right componets to make the music work for Prboom 2.1.1 for windows ?

Share this post


Link to post

This is one of those things that I complain long and hard about to cph whenever I see him on IRC.

Right now, to get hardware MIDI support, you need to use the beta SDL mixer, which has bugs, one of which on my Win98 box would cause the MIDI to not play after the initial title music.

To get software MIDI support (the recommended way, and a very good one at that) you need to get yourself a set of Timidity patches.

They can be downloaded from here:

http://www.anime.net/~goemon/timidity/
(an easier to get/install patch set, but inferior to the one below ...)

http://www.stardate.bc.ca/eawpatches/html/default.htm
(the best one but a pain to get working)

then all you need is to have a timidity.cfg (copied from the 2nd patch set's main directory and change the directories in the file, or copy the goemon.cfg to timidity.cfg if you insist on using the first patch set) file in your prboom main directory for SDL to automatically use timidity for software MIDI synthesis.

And it sounds beautiful :)

Share this post


Link to post
Guest locomotive

AriocH,

I took your advice and grabbed the 2nd set of patches (21 megs!) and put them in a dir in prboom called "eawpats". I'm having trouble setting up the timidity.cfg (which I put in the prboom dir). I tried c:\prboom\eawpats -source gravis.cfg -source gsdrums.cfg -source gssfx.cfg...etc. but it didn't work.

Any suggestions?

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
×