Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
SuperSimsam

What is this error about?

Recommended Posts

I've been making a map recently in GZDoom Builder and every time I open a map with the doom2.iwad it displays an error message that reads:

"Missing sprite lump 'PISTA0'. Forgot to include required resources?"

So it seems like the iwad is missing a sprite lump of some sort. I tried reinstalling the iwad from Steam, but with no avail. My map or game is not affected by this error at all, as I can still edit and test my map, but it's just been bugging me. I have also searched this up on Google and have found nothing much but a ZDoom forum post that had the same error, but a completely different cause. I think the error could be involved with a pistol sprite, or something like that, as the name PISTA0 sounds like a frame of animation for the pistol weapon.

Heres a screenshot:
http://imgur.com/aI4U3hs

I hope you guys can help me.

Share this post


Link to post

Don't worry, your IWAD is OK, this is GZDoomBuilder's false alert bug. "PISTA0" is a ZDoom-exclusive pistol pickup sprite, located in zdoom.pk3 (not in Doom2.wad). It's apparently an error in GZDoomBuilder's newest version which expects zdoom.pk3 to be loaded even though you're not editing for ZDoom or don't need to load zdoom.pk3 whatsoever.

Share this post


Link to post

The editor won't give you this "error" if you're using non-ZDoom-based configurations such as vanilla Doom or Boom, to name a couple.

Loading the .pk3 is harmless. Just be sure to tick that option to disallow it from being loading when testing the map from within the editor.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×