Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Da Eediot

Doomsday Engine WAD Error

Recommended Posts

So, I made this WAD in Doom Builder 2. And it's working fine when I test it on Doomsday Engine. But I later make this one room completely dark, and when I test it, I get an error that says:

Application terminated due to exception:
Uncaught exception during loop iteration:
[MissingSectorError] (Line::Side::sector) No sector is attributed

I tried to fix it by changing the lighting in the WAD, but that didn't work. And I tried to use my .bak WAD files, but they still got that error. Please help!

Share this post


Link to post

Given the error message, it seems you have a sidedef without sector reference. Run DB2's error checker to see if it finds it.

Share this post


Link to post

What else did you change besides the darkness? That shouldn't break it unless there's some weird code in the engine that stops it rendering 0 light sectors properly.

Share this post


Link to post
Gez said:

Given the error message, it seems you have a sidedef without sector reference. Run DB2's error checker to see if it finds it.

How do I run Doom Builder 2's error checker?

SavageCorona said:

What else did you change besides the darkness? That shouldn't break it unless there's some weird code in the engine that stops it rendering 0 light sectors properly.

I'm 99% certain I only changed the darkness. I can't remember changing anything else in that room. Do you know what causes that error?

Share this post


Link to post
Da Eediot said:

How do I run Doom Builder 2's error checker?

The so-called "Map Analysis Mode" (= Error Checker) is available as a "V" icon on the top panel, next to "Find and Replace" (magnifying glass icon).

Share this post


Link to post
scifista42 said:

The so-called "Map Analysis Mode" (= Error Checker) is available as a "V" icon on the top panel, next to "Find and Replace" (magnifying glass icon).

Oh. I found it. Thank you. I'm using it now, so I'll tell you if it fixes my problem or not.

Oh my god! It works now! Thank you! :D

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×