Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Marnetmar

Non-64x64 flats make zdoom spaz out

Recommended Posts

I'm going to assume this is a "feature" rather than a bug, so my question here is if there's a way to get around it.

I have a 32x96 console texture for specific use like so:



But in game, it gets turned into a mixing board:



The way I've worked around this in the past is by splitting textures like these into multiple 64x64 flats, but it's really starting to get old. Is there a way to get around this?

Share this post


Link to post

I'm not an expert on the software renderer, but I believe that flat sizes need to be a power of two to be rendered correctly.

It may also be that some conversion went wrong. It's hard to guess from just a screenshot. Post an example mod that can be tested.

Share this post


Link to post

It does work correctly in GZDoom, so it's only the software renderer that's crapping out, and it's because of the non-power-of-two dimensions. 32x128 works. Just add an extra 32x32 area with some blinkenlights or whatever and it'll be okay.

I made my own example mod by merely dragging the picture from my browser, dropping it in a new wad tab in SLADE, renaming it CONSOLE and converting it to PNG, and making a simplistic two-sector maps.

Then I made a TEXTURES lump like this:

Texture CONS128, 32, 128
{
	Patch CONSOLE, 0, 0
	Patch SW2S0, 0, 96
}
And after replacing CONSOLE by CONS128 in the map, it worked in ZDoom.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×