Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Tezur0

Starting private coop sessions

Recommended Posts

Hi guys, we were doing some coop back in days in chocolate doom, but now commands doesn't seem to work, they just give some crap about master server not being available. We just want to play p2p, so why would master server be an issue at all?

chocolate-doom -server -iwad TNT.wad -skill 4 -warp 01 -record TNT-practice -maxdemo 10000 -port 6500 - server command line



chocolate-doom.exe -width 1024 -height 800 -iwad TNT.wad -warp 01 -skill 4 -connect ip:port -record opdemo -maxdemo 2000 -statdump dump.txt - client command line

can somebody help with this? we are using latest chocolate doom

Edit. even when we are not having that master server thing (-privateserver command instead of server, we just won't be able to connect to each other)

Share this post


Link to post

Are you on the same network or separate networks?

On another note, you can disable the vanilla demo limit by going into Chocolate Doom Setup and visit the Compatibility option.

Share this post


Link to post

We are playing from different networks. From different countries aswell, but that wasn't problem before.
We also played a bit around with firewalls and it didn't seem to have any effect, unless there is something else...

Share this post


Link to post

When you start a server, it registers itself automatically with the global master server. If the other players are using the setup tool to launch the game, they will see the server listed when they search, and won't need to manually enter an IP address.

So if you're manually specifying the IP, it doesn't necessarily matter if the server couldn't register with the master server, since you're not using it at the other end to look up the server anyway.

However, *if* your server failed to register, there's a good chance it's because of a deeper problem in that your server is not publicly accessible on the Internet. Usually this is because it's behind a firewall or NAT gateway - ie. your server is running on your local network but you haven't configured your router to make it publicly accessible. It's usually a fairly simple matter of setting up a port forward on your router's configuration page.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×