Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Thenuke

[ZDOOM] No HUD on Automap?

Recommended Posts

Hi, I just wanted to try playing DOOM without HUD just for fun but there was a BIG major problem, automap still shows the HUD. I don't use alternate HUD, I don't like it.

Is there a way to disable this? I tried a SBARINFO with:

SBARINFO automap {}
But it doesn't work properly, automap doesn't stretch well.

So is there a way to remove HUD on Automap?

Share this post


Link to post

Yeah, I tried, but it's not that I don't like it but it feels better playing with original automap.

Share this post


Link to post
Thenuke said:

I tried a SBARINFO with:

SBARINFO automap {}
But it doesn't work properly, automap doesn't stretch well.

1. It should be "StatusBar Automap {}", but I guess you just typoed it in your post, not in your SBARINFO.
2. How do you mean "doesn't stretch well"? When I tried it, it stretched normally, the only problem was that non-automap status bar vanished as well.

Share this post


Link to post

Sorry my mistake; what port/version are you using? I'm using GZDOOM 1.8.10.

When I say it doesn't stretch well, the place where there was status bar is transparent and shows bottom of the "normal" screen + the green wall for both sides.

Share this post


Link to post

I see no such an issue in either GZDoom 2.1.*, Zandronum 2.1.2 or ZDoom 2.7.1.

Or wait, by "normal screen", do you mean the player's point-of-view-on-the-game-world-or-the-automap screen? In that case - what did you want to see instead?

Can you post a screenshot, please?

Share this post


Link to post



Yeah, it doesn't stretch to the bottom of the screen so I can see through it. It's ugly.

(Black glove is because of Smooth DOOM)

Share this post


Link to post

Try using lesser screen resolution and/or updating GZDoom to post-2.0 version.

Me, GZDoom 2.1.*, 640x480:

Share this post


Link to post

If you really already tried all of the things I advised you before, and really succeeded to make your GZDoom use my config but the issue persisted, the last thing I can think of is to try updating your graphic card driver.

Share this post


Link to post
Edward850 said:

You said you updated, but you never stated what you updated to, let alone if you went anywhere near drdteam.


Then, what do I do next? I tried, but it doesn't work. Again.

Share this post


Link to post

Okay, the problem here is that the default Doom statusbar code has a setting of height 32; which means it reserves 32 pixels of statusbar canvas for the bar in both Normal and Automap bars. Because the Automap statusbar is defined to be blank, it is still allocating the 32 pixels of bar space, but it has nothing to render there, so it becomes see-through.

You could try setting height to 0 outside of your statusbar block, but bear in mind that if you're using the normal statusbar (and not the fullscreen version), your field of view and weapon sprite will be tucked behind the statusbar.

Share this post


Link to post

HOLY ****!!!!!!!!!!!!!!!!!! IT WORKS!!!!

height 0 ; StatusBar Automap {}
Thank you, Weasel!!!!!!!!!!!!!!!!!!!!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×