Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Impie

can't get 100% items

Recommended Posts

I've been working on the 4.0 release of Strange Aeons with a bunch of fixes. Skepticist has been playtesting the mod and brought a bizarre bug to my attention:

Apparently, on certain maps, it's impossible to get 100% items, even if the (g)zdoom hud says you got them all. It happens on E2M2, E2M6, E3M3, E3M5, and E4M5.

I can't fathom what's causing this. At first I thought it was a furniture object that was accidentally tagged as an item somehow, but I checked them all and no dice. Then I thought maybe the rain effect was tagged as an item, but most of the maps listed don't feature any rain. And I can't find any items in the void outside of the map.

Any ideas? I'm totally clueless, as usual.

Share this post


Link to post
Linguica said:

Multiple automaps.

Sorry, I'm not sure what you mean by this, except that it can't be "too many automap powerups". I'm trying to find mention of automap bugs on the 'net to see if that's what you're referring to, but nothing's coming up.

EDIT: Skep thinks it's the mutant sphere powerup causing it, but I can't see how in the code. I'm gonna post the issue over there, unless somebody here can spot what's causing it in the decorate code.

Share this post


Link to post
Impie said:

Sorry, I'm not sure what you mean by this, except that it can't be "too many automap powerups". I'm trying to find mention of automap bugs on the 'net to see if that's what you're referring to, but nothing's coming up.

My first thought is that it was the bug where if a map has multiple automap powerups, only one can be collected, and it prevents the player from getting 100% items. It could be a similar thing.

Share this post


Link to post

Oh, so that IS what you meant. I checked the first map listed and there's only one automap powerup on all difficulties. Skep also didn't mention a number of the maps that have the mutant sphere, so I'm not 100% certain if it's the cause either, although he said when he deleted it from one map, he was able to get 100% items. I just can't see where this is occurring in the code because it's a complicated item.

Share this post


Link to post

If any of your custom DECORATE-defined items changes its "COUNTITEM" flag during its life, or disappears / gets removed from the map before being collected, (or maybe gets dynamically spawned during the map or dropped by a dying enemy as opposed to being pre-placed in a map editor - this is the least probable cause, though), that's almost certainly the source of the problem.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×