Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
volumetricsteve

static lighting seems to have given up

Recommended Posts

I'm using the latest version of gzdoom builder, and I've started to notice that when I throttle down the brightness of a sector, the change is immediately visible in the editor, but when I check it out ingame, it's like I didn't change anything at all unless I set the brightness of the sector to zero.

It's been ok in some parts where I do only hand-placed dynamic lights, so I black them out before I do that, but in a room i'm working on now I want very...very dim static light, but I can't seem to achieve that effect.

Share this post


Link to post

Works for me™

To change the brightness of a sector you have to be in Sectors Mode.

    1. Click the View Brightness Levels icon. This will show the current brightness of each sector.

    2. Now you can click the Full Brightness icon to toggle full brightness on or off.
    Leave it off.

    3. Press and hold the Ctrl button while rolling the mouse wheel up or down, the brightness
    of the sector that the mouse cursor is in, or the selected sectors, will either darken of brighten
    in 8 unit steps.

    4. Test the map to check if the brightness level(s) is (are) okay.

    5. Make further changes and/or save the map.

Share this post


Link to post

I've been doing all that, I'll double check though..

I saw in another thread:

https://www.doomworld.com/vb/doom-editing/61613-dark-sectors-in-doom-builder-2/

It might just be an opengl thing, something with how the engine works.


It's almost like....192 is bright. anywhere between 192 and 8 is bright, but gets slightly more dim towards 8. then, 0 is pitch black, it just drops off instantly.

I can reduce brightness but it's like I can go from bright to slightly-less bright, or black.

Share this post


Link to post

I assume you're using GZDoom, correct me if I'm wrong. Did you change any default settings in "Display Options"? Particularly check out "Display Options -> OpenGL Options -> Preferences -> Sector Light Mode". If it's not set to "Dark", it will likely be strongly overbright in comparison to software rendering ports, and even the "Dark" mode is noticeably brighter than software mode.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×