Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Error inheriting classes from Doom2.wad

Recommended Posts

Last time I opened GZDoom builder, everything worked just fine and I don't recall changing anything, but a number of actors I took from Smooth Doom don't recognize their parent classes from DOOM2.wad and gzdoom.pk3

I'm talking about pistol, shotgun, RocketLauncher, blood, Doomimpball, etc.

Anyone knows what might be causing it? There is no error report, GZDoombuilder just says this with every line

"DECORATE warning in 'deco\Particles.txt', line 219. Unable to find 'teleportfog' class to replace, while parsing 'smoothfog'."

Share this post

Link to post

This happens in a certain version of GZDoom Builder which I don't ought to remember. Try updating, if you didn't already.

If you are already in a newer version, then tell what other WADs you're loading as Scifista suggested.

Share this post

Link to post

I'm loading a bunch of .pk3s i packed together, each containing different stuff from different places, but all those worked before, they can't be the problem. I tried moving Doom2.wad to different places in the loading priority list, but none of that worked. It's strange because it only reports error of class inheritance from original Doom actors, like it tries to load first the smooth doom stuff and then doom2.wad, no matter what order it's in the list.

Well I'll be damned, it suddenly started working when I test it, even though it still displays the error messages in the editor. This must be a bug in the editor, it's too random.

Share this post

Link to post

Is gzdoom.pk3 among the list of resources? If not, add it, but check the "exclude this resource from testing parameters" checkbox, and see if it helps.

Of course that this is an editor-fake-warning-only issue. GZDoom or any other ZDoom-based engine will never actually forget the in-built default classes (provided that their base file (GZDoom's one is "gzdoom.pk3") stays unmodified).

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now