Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
doomedwarrior1981

GZDoom has been acting weird since I upgraded to Windows 10

Recommended Posts

If I start Gzdoom in a window and then switch to fullscreen it works fine however if I try to boot up in fullscreen I get a black screen yet the music plays and I see the cursor this has been happening since I installed Windows 10. Anyone else got this issue and how did you resolve it. Please help it's rather annoying having to go into my Gzdoom config file first and switching full screen to false I didn't have this issue before I installed Windows 10.

Share this post


Link to post

Have you updated your video drivers after moving from Windows * to Windows 10?

Share this post


Link to post

Not the best solution but you should be able to use alt+enter to switch to and from fullscreen.

Share this post


Link to post
Gez said:

Have you updated your video drivers after moving from Windows * to Windows 10?


How do I find out what video card I have my computer is previously owned from Rentacenter. It didn't come in a box so I have no idea what video card I have. To answer your question no I haven't updated since moving from old Windows to Windows 10.

In device manager I have something listed called Intel HD Graphics under Display adapters is that my graphics card. If so I just tried to install drivers but Windows told me when I was installing that they were older than the ones I have. Well I installed them anyway and that issue in the original post is still occurring
Do I need to update something else like Direct3d drivers or something like that.

plums said:

Not the best solution but you should be able to use alt+enter to switch to and from fullscreen.

That doesn't work cause for some reason when I try to switch from full screen to a window Gzdoom always crashes (that crash didn't happen before I installed Windows 10 btw). Another weird thing is Gzdoom is the only 3d accelerated program that I ran into the blank black screen issue. Please I'm pretty sure that I'm not the only one that ran into the problem any solutions would be appreciated. I've even tried older versions of Gzdoom to see if maybe it was a Gzdoom issue but no luck.

Share this post


Link to post

Direct3D drivers should be entirely irrelevant as far as GZDoom is concerned, it's the OpenGL drivers that matter.

Here are the official Intel HD graphics driver for Windows 10: 32-bit 64-bit

Share this post


Link to post

As a first step, it might be a good idea to save the startup log to a file (start the engine with '+logfile log' command line parameter) and post that output here.

Remote diagnosing a problem without any information is not really possible.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×