Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
NiKMic

DOOM Legacy freezes just before I start a game.

Recommended Posts

Hi. Once again, apologies if this is in the wrong forum section!

I downloaded DOOM Legacy source (1.45.2_source on sourceforge) and compiled it using the make command and parameters LINUX=1 HAVE_MIXER=1 DEBUG=1. I downloaded the DOOM 1 shareware WAD along with the legacy wad provided on sourceforge and put them in the same directory of the binary executable.

When I run the game I am presented with a screen containing a number of text fields for the paths of the Home directory, Doomwaddir directory etc. My Home and Doomwaddir paths are filled in correctly but the other 3 paths (config, switch, IWAD) are empty. My wads are in the same directory of the executable, so it should be ok.

The problem is that when I chose the difficulty, the game crashes. It kinda freezes and doesn't start the game. I know that the wad is ok since it runs with Chocolate DOOM and it fails with a different legacy.wad file (downloaded elsewhere).

I'm not sure what I'm doing wrong. I'm working on Linux too, so I should be ok.

Any ideas? Thanks.

EDIT: Same problem as EDIT 1 here: https://www.doomworld.com/vb/post/1352901

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×