Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
BluetheIncubus

Need some help, errors compiling ACS code

Recommended Posts

Hello there. Yes, I know I am new here, but I am not new to was editing and creating... it's just none of my old projects have never seen the light of day before. Anyway, now to the meat of this. I have used another wad as a sort of example to write this string of code, take a look.

script 1 OPEN


setfont ("BigFont");
hudmessage (s:"great grass zone"; 2, 0, CR_GREEN, 0.5, 0.46, 5.0, 0.01, 1.0);
delay(6);
hudmessage (s:"act "; 2, 0, CR_BLUE, 0.5, 0.53, 4.83, 0.01, 1.0);
hudmessage (s:" 1"; 2, 0, CR_WHITE, 0.5, 0.53, 4.83, 0.01, 1.0);
delay(24);
ACS_Execute (400, 0, 0, 0, 0);
}

However, it will not compile for some strange reason, saying that there is some error with "hudmessage" like it is not recognized or something. I find this hard to believe, as even Terry wads can easily use stuff like hudmessage. Am I doing something wrong? Can any of you help me with this? If so, I will be very grateful, and will most likely give you credit for helping me and such.

-BluetheIncubus

Share this post


Link to post

1. You're missing an opening curly bracket after "script 1 OPEN".

2. The very first line in SCRIPTS should be:

#include "zcommon.acs"
Which enables ZDoom's ACS functions.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×