Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Keyboard_Doomer

How to fix pacifist monsters placed in a sector without a line of sight to the player

Recommended Posts

The map in question is map16 of Interception. Expanding on a coopfix for this WAD I want to remedy these bugged monsters to make the gameplay as it was supposed to be.

The arachnotrons and mastermind placed on pillars in the outside area cannot see or hear the player and only wake up after you shoot them. Even after that they never attack.

I suppose this is a problem with REJECT table but I don't know how to fix it. I tried deleting the REJECT lump and rebuilding the nodes to force creating a new REJECT table but that didn't help.

Any idea how to solve this?

Share this post


Link to post

There are 2 possible causes:
1. REJECT error. Solution: Try several different node builders to rebuild the REJECT until one works alright.
2. Sleeping monster bug. Solution: Move the monsters slightly (like by 1 map unit) along both X and Y axes.

EDIT: Seeing that you wrote "Even after that they never attack", it's almost certainly a REJECT error.

Share this post


Link to post
Keyboard_Doomer said:

Ticking off "Don't build REJECT"

Note that maps without a REJECT lump or with zero-sized one are vanilla incompatible. If you aimed for vanilla compatibility, you should prefer using a node builder that does build REJECT, at least one filled with all zeros (which is a different situation than zero-sized REJECT lump, and vanilla can take it).

http://doomwiki.org/wiki/REJECT

Share this post


Link to post

Thanks for the additional info. However, it seems that even with this option used ZenNode does still create a REJECT lump (with the same size as the original one). I assume the new one is simply filled with zeros. The resulting map does work in vanilla.

Share this post


Link to post
Keyboard_Doomer said:

I assume the new one is simply filled with zeros.

In SLADE3, you can right click the lump and choose "View as -> View as Hex", and if you saw all zeroes there, you would know for sure. Alternatively export the lump into a file and view the file in any Notepad-like program that has a "binary mode".

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×