Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Frisky

GZDoom - No Sounds or Music (and is now super broken)

Recommended Posts

I was going to start playing on GZDoom again after a while, so I deleted a few unneeded WADs and PK3s. I started GZDoom, but there is no sound or music.
I'm not sure what the problem is. I've checked my sound settings and volume, but I don't know how to solve it.

Can somebody please help?

Share this post


Link to post

You posted too little information about your problem. Operating system? Architexture? Sound Drivers? Sound card? Version of GZDoom?

*avoids getting shot by Damerell*

Share this post


Link to post

Or more importantly, the startup log! (Start GZDoom with +logfile somelogfilename.txt)
"Help I have an error" is not as descriptive as showing us what the error actually is.

Share this post


Link to post
Edward850 said:

Or more importantly, the startup log! (Start GZDoom with +logfile somelogfilename.txt)
"Help I have an error" is not as descriptive as showing us what the error actually is.

How do I start GZDoom with that? Also, it's just straight up not even working anymore since I updated to 2.1.1.

Danfun64 said:

You posted too little information about your problem. Operating system? Architexture? Sound Drivers? Sound card? Version of GZDoom?

*avoids getting shot by Damerell*

My operating system is Windows 10 and like I said, my version of GZDoom is 2.1.1.

Share this post


Link to post

Make sure that the following files are in your GZDoom folder: "gzdoom.pk3", "fmodex.dll", "libsndfile-1.dll", "OpenAL32.dll". My suspiction is that maybe you accidentally deleted one or more of them.

Share this post


Link to post
Frisky said:

Honestly, I need a step-by-step tutorial on how to do that, because I have never actually done that before or seen anybody do that.

We've been doing it for atleast 20 years of Windows.
In Windows 10, you can hold shift+right click the empty space in your GZDoom folder (with nothing selected), and select the option "open command window here". Then it's just as simple as typing 'gzdoom +logfile thisisstillalogfilename.txt' and hitting enter.

You have several other ways you can open a command prompt as well. Windows 10 especially doesn't exactly hide it.

Share this post


Link to post

Thanks!
This is the full log.

Spoiler

Log started: Mon Apr 18 02:21:25 2016

M_LoadDefaults: Load system defaults.
Using program directory for storage
Gameinfo scan took 0 ms
W_Init: Init WADfiles.
adding C:/Users/Ace/Games/GZDoom/gzdoom.pk3, 610 lumps
adding ./doom2.wad, 2919 lumps
I_Init: Setting up machine state.
CPU Speed: 2295 MHz
CPU Vendor ID: GenuineIntel
Name: Intel(R) Core(TM) i3-2350M CPU @ 2.30GHz
Family 6, Model 42, Stepping 7
Features: MMX SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
I_InitSound: Initializing FMOD
FMOD Sound System, copyright © Firelight Technologies Pty, Ltd., 1994-2009.
Loaded FMOD version 4.44.61
V_Init: allocate screen.
S_Init: Setting up sound.
ST_Init: Init startup screen.
Checking cmd-line parameters...
S_InitData: Load sound definitions.
G_ParseMapInfo: Load map definitions.
Texman.Init: Init texture manager.
ParseTeamInfo: Load team definitions.
LoadActors: Load actor definitions.
R_Init: Init Doom refresh subsystem.
DecalLibrary: Load decals.
M_Init: Init menus.
P_Init: Init Playloop state.
ParseSBarInfo: Loading default status bar definition.
ParseSBarInfo: Loading custom status bar definition.
D_CheckNetGame: Checking network game status.
player 1 of 1 (1 nodes)
I_InitInput
I_StartupMouse
I_StartupKeyboard
I_StartupXInput
I_StartupRawPS2
I_StartupDirectInputJoystick
Warning: 'Object' is freed outside the GC process.

And like I said, GZDoom just simply "won't work."

Share this post


Link to post

GZDoom seems to be starting up your sound fine. It's either an external problem (you haven't accidentally muted GZDoom in the windows mixer have you?) or a conflict that GZDoom isn't picking up (you must be using only the DLLs packaged with the build of GZDoom you grabbed).

Make sure you're also running the latest build.

Still failing that, also try removing your gzdoom-Ace.ini config file.

Share this post


Link to post
Edward850 said:

GZDoom seems to be starting up your sound fine. It's either an external problem (you haven't accidentally muted GZDoom in the windows mixer have you?) or a conflict that GZDoom isn't picking up (you must be using only the DLLs packaged with the build of GZDoom you grabbed).

Make sure you're also running the latest build.

Still failing that, also try removing your gzdoom-Ace.ini config file.

I got the latest build and GZDoom still continues to be broken.

Share this post


Link to post
Frisky said:

I got the latest build and GZDoom still continues to be broken.


Does your sound card work in other applications? Are you only experiencing the problem in GZDoom?

Share this post


Link to post
Master O said:

Does your sound card work in other applications? Are you only experiencing the problem in GZDoom?

Yes. It works perfectly in ZDoom, but not GZDoom.

Share this post


Link to post

There's also the possibility that you have ended up with a "Franken-GZDoom" installation: a mixture of new and old libraries and user .ini files as a result of "installing" (actually, just unzipping a file) into the same folder over multiple revisions. Most of the time, it will work asymptomatically. Other times, it will clamorously fail.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×