Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Poormetheus

Sideways Armor

Recommended Posts

I have tainted my Brutal Doom pk.3 file.

I was using SlumpED, trying to alter the spectre sprite. When I returned to play a map, I noticed that ALL ARMOR PICUPS ARE NOW SIDEWAYS!!!!

Even on SlumpED or SLADE3, the sprite itself appears sideways, and there is no way to rotate sprites 360 degrees, only flip them, etc.

Any help to get me out of this annoying situation would be much appreciated.

I'd post pictures but apparently my rank isn't high enough to do so!

Share this post


Link to post
VGA said:

You buggered your pk3? Download the pk3 again. :D


Awh but won't that mean that I'll need to optimize it once again. I had all settings perfect . . . :/

Share this post


Link to post

If you're talking about your custom controls and player settings in Brutal Doom, those are not being stored in Brutal Doom's pk3, but in your source port's config, so that redownloading the pk3 will not erase them. If you're talking about modifications that you've done to your copy of Brutal Doom's pk3 via SLADE3/zip, that's another thing, of course.

Share this post


Link to post
Poormetheus said:

Awh but won't that mean that I'll need to optimize it once again. I had all settings perfect . . . :/

You can copy/past your edits .

Share this post


Link to post

Okay cool. I guess it necessitates downloading BD once again. It's a relief to know that my settings won't be erased.

I'll wait a while, though. I am using this 'now corrupt' pk3 of Brutal Doom as a testing ground.

Currently trying to mod in the nightmare spectre from PSX doom, and it's BREAKING MY HEART!!

Share this post


Link to post
Jaxxoon R said:

Why not just edit the armor bonus sprites in an external image editing program?


Because I suck at image editing. I am nothing of a visual artist, that's for sure.

UPDATE: I RE-DOWNLOADED BRUTAL2.0 and guess what?

My armor is STILL slanted. Can you believe that??

Any help would be GREATLY appreciated . . .

Share this post


Link to post

Sounds like you must might be still playing with the old version rather than the redownloaded one. Isn't it still in your autoload folder, or among the CMD/launcher parameters that you're launching the game with?

Share this post


Link to post
scifista42 said:

Sounds like you must be still playing with the old version rather than the redownloaded one. Isn't it still in your autoload folder, or among the CMD/launcher parameters that you're launching the game with?


I use ZDL to queue up WADs that I wish to use. In this case I replaced the old one (which was in a directory on my B:\) and added the new one, which was on (C:\Users \John\Desktop).

So technically these are two totally different WAD files, right? How strange that this STILL didn't rectify the slanted armor . . .

Share this post


Link to post
scifista42 said:

And if you open the new one in SLADE3, do you see slanted or normal armor?


Yes I do. Bizarre, right?? Something is interfering with ARM1 and ARM2, or whatever they're called. The actual sprites themselves are angled . . .

. . . . but let me be clear, this ONLY applies to Brutal Doom.

If I run Gzdoom with no megawad, just basic DOOM II, I have the vanilla armor and it is perfectly centered.

Share this post


Link to post

And what about the other changes that you've done to your old BD copy, are they present in the new one too? If they are present, you must have just confused the old copy for the new one.

Share this post


Link to post
scifista42 said:

And what about the other changes that you've done to your old BD copy, are they present in the new one too? If they are present, you must have just confused the old copy for the new one.


That's a good question - I'm at work right now so I can't play test anything. Allow me to get home later and I'll report back with my news.

P.S - Thank you in advance for weathering my storm of issues!

Share this post


Link to post

Okay so I deleted my previous Brutalv2.0 wad file, downloaded a new one, and tried it out.

SLANTY ARMOR! Something must be radically wrong.

I currently have another wad called 'BrutaldoomTEST' on my desktop; basically it's the wad that I use on Slade to learn things and mess around (I'm trying to get better at scripting, etc.).

Could that be interfering with it?

Share this post


Link to post
Poormetheus said:

Could that be interfering with it?

Only if you have it auto-(or otherwise)-loaded when you launch your game, possibly via your source port's config/parameter or ZDL's config/parameter, not for no reason at all.

Share this post


Link to post

So, I deleted every single trace of Brutal Doom from my HDD. . .

Re-downloaded BDv2.0.

SLANTED ARMOR!

Now I am led to believe that it's coming from my DOOM.wad or DOOMII.wad. What do you think? I've seriously just launched Gzdoom.exe with BDv2.0 and nothing else whatsoever. How bizarre. . .

Share this post


Link to post
scifista42 said:

here[/url].


That's precisely where I downloaded from, nay that is exactly the same file I downloaded.

For good measure, I re-downloaded ZDL too. It seemed to automatically know where my wads and .exe files were . . . it remembered their file paths.

UPDATE: I GIVE UP!

I have simply deleted the armor sprites from BD. I'll settle for classic armor with some GL lighting on it . . .

Sigh . .

Share this post


Link to post

As an aside, if ANYONE wants to send me the Brutal Doom armor .png files, I would be very appreciative.

It seems like it's the only way it will work for me . . . I'm grasping at straws here :/

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×